summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
new file mode 100644
index 000000000..4a7db1a4e
--- /dev/null
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
@@ -0,0 +1,22 @@
+python __anonymous() {
+ if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"):
+ msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \
+ "provider of virtual/kernel."
+ raise bb.parse.SkipRecipe(msg)
+}
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
+
+LINUX_VERSION ?= "4.16"
+LINUX_RPI_DEV_BRANCH ?= "rpi-4.16.y"
+
+SRCREV = "${AUTOREV}"
+SRC_URI = " \
+ git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_DEV_BRANCH} \
+ file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \
+ "
+require linux-raspberrypi.inc
+
+# Disable version check so that we don't have to edit this recipe every time
+# upstream bumps the version
+KERNEL_VERSION_SANITY_SKIP = "1"
OpenPOWER on IntegriCloud