summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb')
-rw-r--r--meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb32
1 files changed, 28 insertions, 4 deletions
diff --git a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
index e185f25e2..b2401b93c 100644
--- a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
+++ b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
@@ -6,17 +6,41 @@ LIC_FILES_CHKSUM = "\
file://debian/copyright;md5=6af8de3c8ee71f8e91e9b22f84ff2022 \
"
-SRC_URI = "git://github.com/RPi-Distro/pi-bluetooth"
-SRCREV = "2a7477966bb3c69838b224f3ea92cb49a88124d5"
-UPSTREAM_VERSION_UNKNOWN = "1"
+SRC_URI = "\
+ git://github.com/RPi-Distro/pi-bluetooth \
+ file://0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch \
+"
+SRCREV = "2e1a393955910aea67bbf3c921be35a66e8a8fbe"
+PV = "1.1+git${SRCPV}"
S = "${WORKDIR}/git"
+# hciuart.service replaces what was brcm43438.service
+inherit systemd
+SYSTEMD_SERVICE_${PN} = "\
+ hciuart.service \
+ bthelper@.service \
+"
+
inherit allarch
do_install() {
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0644 ${S}/lib/udev/rules.d/* ${D}${sysconfdir}/udev/rules.d
+
install -d ${D}${bindir}
+ install -m 0755 ${S}/usr/bin/bthelper ${D}${bindir}
install -m 0755 ${S}/usr/bin/btuart ${D}${bindir}
+
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${S}/debian/pi-bluetooth.bthelper@.service ${D}${systemd_system_unitdir}/bthelper@.service
+ install -m 0644 ${S}/debian/pi-bluetooth.hciuart.service ${D}${systemd_system_unitdir}/hciuart.service
+ fi
}
-FILES_${PN} = "${bindir}"
+FILES_${PN} = "\
+ ${bindir} \
+ ${sysconfdir} \
+ ${systemd_unitdir}/system \
+"
OpenPOWER on IntegriCloud