summaryrefslogtreecommitdiffstats
path: root/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map-native.bb')
-rw-r--r--meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map-native.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map-native.bb b/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..8b9e3ceff
--- /dev/null
+++ b/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map-native.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Barreleye IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
+
OpenPOWER on IntegriCloud