summaryrefslogtreecommitdiffstats
path: root/meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb')
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb b/meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb
new file mode 100644
index 000000000..5b2fcf26c
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb
@@ -0,0 +1,19 @@
+# Should RDEPENDS on python at the very least.
+FILESEXTRAPATHS_append := "${THISDIR}/files:"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://spimaster.py;beginline=1;endline=13;md5=b86c59990b35609be34a0ec322a3cfff"
+
+S = "${WORKDIR}/"
+
+SRC_URI = "file://spimaster.py"
+
+DEPENDS = "python"
+
+FILES_${PN} += "*"
+
+do_install() {
+ install -d ${D}/home
+ install -d ${D}/home/root
+ install -m 0755 ${S}/spimaster.py ${D}/home/root/.
+}
OpenPOWER on IntegriCloud