summaryrefslogtreecommitdiffstats
path: root/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb')
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb
new file mode 100644
index 000000000..330cda177
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb
@@ -0,0 +1,14 @@
+inherit native
+inherit obmc-phosphor-license
+
+DEPENDS += "virtual/phosphor-ipmi-fru-inventory"
+PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
+
+# Put the fru_config in the right place with the right name.
+# Pull the IPMI FRU YAML config to use it in the IPMI HOST YAML.
+do_install_append() {
+ IPMI_FRU_SRC=${datadir}/phosphor-ipmi-fru/config
+ IPMI_HOST_DEST=${D}${datadir}/phosphor-ipmi-host/config
+ install -d ${IPMI_HOST_DEST}
+ cat ${IPMI_FRU_SRC}/config.yaml > ${IPMI_HOST_DEST}/fru_config.yaml
+}
OpenPOWER on IntegriCloud