summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/config-in-skeleton.bbclass6
-rw-r--r--meta-phosphor/classes/obmc-phosphor-utils.bbclass13
-rw-r--r--meta-phosphor/classes/skeleton-rev.bbclass2
-rw-r--r--meta-phosphor/classes/skeleton.bbclass4
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py3
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService.conf (renamed from meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService0.conf)4
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService0.conf8
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService1.conf8
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py4
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb3
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c8
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService.conf (renamed from meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService1.conf)4
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb3
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-flash-bmc.bb2
15 files changed, 30 insertions, 44 deletions
diff --git a/meta-phosphor/classes/config-in-skeleton.bbclass b/meta-phosphor/classes/config-in-skeleton.bbclass
index 72249ff1e..907f226e1 100644
--- a/meta-phosphor/classes/config-in-skeleton.bbclass
+++ b/meta-phosphor/classes/config-in-skeleton.bbclass
@@ -4,9 +4,13 @@
inherit allarch
inherit setuptools
inherit pythonnative
+inherit skeleton-rev
+inherit obmc-phosphor-license
+
+HOMEPAGE = "http://github.com/openbmc/skeleton"
DEPENDS += "python"
-SRC_URI += "git://github.com/openbmc/skeleton;subpath=configs"
+SRC_URI += "${SKELETON_URI};subpath=configs"
S = "${WORKDIR}/configs"
python() {
diff --git a/meta-phosphor/classes/obmc-phosphor-utils.bbclass b/meta-phosphor/classes/obmc-phosphor-utils.bbclass
index 4f556294b..44ca7ad62 100644
--- a/meta-phosphor/classes/obmc-phosphor-utils.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-utils.bbclass
@@ -2,13 +2,16 @@
inherit utils
+
def df_enabled(feature, value, d):
- return base_contains("DISTRO_FEATURES", feature, value, "", d)
+ return base_contains("DISTRO_FEATURES", feature, value, "", d)
+
def mf_enabled(feature, value, d):
- return base_contains("MACHINE_FEATURES", feature, value, "", d)
+ return base_contains("MACHINE_FEATURES", feature, value, "", d)
+
def cf_enabled(feature, value, d):
- return value if df_enabled(feature, value, d) \
- and mf_enabled(feature, value, d) \
- else ""
+ return value if df_enabled(feature, value, d) \
+ and mf_enabled(feature, value, d) \
+ else ""
diff --git a/meta-phosphor/classes/skeleton-rev.bbclass b/meta-phosphor/classes/skeleton-rev.bbclass
new file mode 100644
index 000000000..93544de6f
--- /dev/null
+++ b/meta-phosphor/classes/skeleton-rev.bbclass
@@ -0,0 +1,2 @@
+SRCREV ?= "b4140b888f586c98c5d03893166c5074a98cf951"
+SKELETON_URI ?= "git://github.com/openbmc/skeleton"
diff --git a/meta-phosphor/classes/skeleton.bbclass b/meta-phosphor/classes/skeleton.bbclass
index 3faaa1573..1f673333b 100644
--- a/meta-phosphor/classes/skeleton.bbclass
+++ b/meta-phosphor/classes/skeleton.bbclass
@@ -1,7 +1,7 @@
inherit obmc-phosphor-license
+inherit skeleton-rev
HOMEPAGE = "http://github.com/openbmc/skeleton"
-SRCREV ??= "1bbc820f2b595b7a674e52bee1775c877b35b61e"
-SRC_URI += "git://github.com/openbmc/skeleton"
+SRC_URI += "${SKELETON_URI}"
S = "${WORKDIR}/git/${SKELETON_DIR}"
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
index 2a761de21..a891df6bf 100644
--- a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
@@ -19,7 +19,7 @@ RDEPENDS_${PN} += "settings"
RDEPENDS_${PN} += "network"
SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid"
-SRCREV = "b7bcda57ee39616e8937194d281e2476e6ea8df2"
+SRCREV = "87e080b537aff3fd22ec56ef72660937bed38422"
S = "${WORKDIR}/git"
INSTALL_NAME = "ipmid"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py
index 2b59b5887..1f4ce90bb 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py
@@ -86,8 +86,7 @@ if __name__ == '__main__':
bus = dbus.SystemBus()
services = []
- services.append(dbus.service.BusName(SERVICE_PREFIX + '.PythonService0', bus))
- services.append(dbus.service.BusName(SERVICE_PREFIX + '.PythonService1', bus))
+ services.append(dbus.service.BusName(SERVICE_PREFIX + '.PythonService', bus))
objs = []
objs.append(SampleObjectOne(bus, BASE_OBJ_PATH + 'path0/PythonObj'))
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService0.conf b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService.conf
index 45af4f4b6..6c4a71314 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService0.conf
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService.conf
@@ -2,7 +2,7 @@
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
<policy user="root">
- <allow own="org.openbmc.examples.SDBusService0"/>
- <allow send_destination="org.openbmc.examples.SDBusService0"/>
+ <allow own="org.openbmc.examples.PythonService"/>
+ <allow send_destination="org.openbmc.examples.PythonService"/>
</policy>
</busconfig>
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService0.conf b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService0.conf
deleted file mode 100644
index fad0b81fb..000000000
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService0.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy user="root">
- <allow own="org.openbmc.examples.PythonService0"/>
- <allow send_destination="org.openbmc.examples.PythonService0"/>
- </policy>
-</busconfig>
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService1.conf b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService1.conf
deleted file mode 100644
index 0f7114e48..000000000
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService1.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy user="root">
- <allow own="org.openbmc.examples.PythonService1"/>
- <allow send_destination="org.openbmc.examples.PythonService1"/>
- </policy>
-</busconfig>
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py
index e1010a542..138865db0 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py
@@ -36,9 +36,9 @@ if __name__ == '__main__':
bus = dbus.SystemBus()
- obj0 = bus.get_object(SERVICE_PREFIX + '.PythonService0',
+ obj0 = bus.get_object(SERVICE_PREFIX + '.PythonService',
BASE_OBJ_PATH + 'path0/PythonObj')
- obj1 = bus.get_object(SERVICE_PREFIX + '.PythonService1',
+ obj1 = bus.get_object(SERVICE_PREFIX + '.PythonService',
BASE_OBJ_PATH + 'path1/PythonObj')
echo0= dbus.Interface(obj0,
dbus_interface=IFACE_PREFIX + '.Echo')
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
index 1446a7313..57e27cf78 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
@@ -3,8 +3,7 @@ DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation."
PR = "r1"
DBUS_SERVICES = " \
- org.openbmc.examples.PythonService0 \
- org.openbmc.examples.PythonService1 \
+ org.openbmc.examples.PythonService \
"
inherit obmc-phosphor-pydbus-service
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c
index a66bb555c..769a2081f 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c
@@ -79,13 +79,7 @@ int main(int argc, char *argv[]) {
}
/* Take a well-known service name so that clients can find us */
- r = sd_bus_request_name(bus, "org.openbmc.examples.SDBusService0", 0);
- if (r < 0) {
- fprintf(stderr, "Failed to acquire service name: %s\n", strerror(-r));
- goto finish;
- }
-
- r = sd_bus_request_name(bus, "org.openbmc.examples.SDBusService1", 0);
+ r = sd_bus_request_name(bus, "org.openbmc.examples.SDBusService", 0);
if (r < 0) {
fprintf(stderr, "Failed to acquire service name: %s\n", strerror(-r));
goto finish;
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService1.conf b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService.conf
index 5a7bfb84e..86e2a53fa 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService1.conf
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService.conf
@@ -2,7 +2,7 @@
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
<policy user="root">
- <allow own="org.openbmc.examples.SDBusService1"/>
- <allow send_destination="org.openbmc.examples.SDBusService1"/>
+ <allow own="org.openbmc.examples.SDBusService"/>
+ <allow send_destination="org.openbmc.examples.SDBusService"/>
</policy>
</busconfig>
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
index f1a9eb962..9a3018d37 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
@@ -3,8 +3,7 @@ DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation."
PR = "r1"
DBUS_SERVICES = " \
- org.openbmc.examples.SDBusService0 \
- org.openbmc.examples.SDBusService1 \
+ org.openbmc.examples.SDBusService \
"
S = "${WORKDIR}"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-flash-bmc.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-flash-bmc.bb
index 80bd1bf4f..3c412205c 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-flash-bmc.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-flash-bmc.bb
@@ -9,6 +9,8 @@ RDEPENDS_${PN} += "\
python-compression \
python-shell \
python-pygobject \
+ python-subprocess \
+ python-io \
pyphosphor \
"
OpenPOWER on IntegriCloud