summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rwxr-xr-xmeta-phosphor/aspeed-layer/recipes-connectivity/jsnbd/jsnbd/state_hook68
-rw-r--r--meta-phosphor/aspeed-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend9
-rw-r--r--meta-phosphor/classes/obmc-phosphor-image.bbclass2
-rw-r--r--meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb4
-rw-r--r--meta-phosphor/recipes-graphics/obmc-ikvm/obmc-ikvm_git.bb4
-rw-r--r--meta-phosphor/recipes-phosphor/console/obmc-console/obmc-console-ssh@.service12
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb16
-rwxr-xr-xmeta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh31
-rw-r--r--meta-phosphor/recipes-phosphor/initrdscripts/files/whitelist5
-rw-r--r--meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb12
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb/0001-Increase-request-limit.patch15
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb6
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb4
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb4
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb49
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/state/files/phosphor-reset-host-reboot-attempts@.service2
-rw-r--r--meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb4
18 files changed, 221 insertions, 28 deletions
diff --git a/meta-phosphor/aspeed-layer/recipes-connectivity/jsnbd/jsnbd/state_hook b/meta-phosphor/aspeed-layer/recipes-connectivity/jsnbd/jsnbd/state_hook
new file mode 100755
index 000000000..0df6ff973
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-connectivity/jsnbd/jsnbd/state_hook
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+if [ $# -ne 2 ]
+then
+ echo "usage: $0 <start|stop> <config>" >&2
+ exit 1
+fi
+
+action=$1
+config=$2
+
+gadget_name=mass-storage
+gadget_dir=/sys/kernel/config/usb_gadget/$gadget_name
+
+case "$config" in
+0)
+ nbd_device=/dev/nbd0
+ ;;
+*)
+ echo "invalid config $config" >&2
+ exit 1
+ ;;
+esac
+
+set -ex
+
+case "$action" in
+start)
+ mkdir -p $gadget_dir
+ (
+ cd $gadget_dir
+ # http://www.linux-usb.org/usb.ids
+ # |-> 1d6b Linux Foundation
+ # |-> 0104 Multifunction Composite Gadget
+ echo "0x1d6b" > idVendor
+ echo "0x0104" > idProduct
+ mkdir -p strings/0x409
+ echo "OpenBMC" > strings/0x409/manufacturer
+ echo "Virtual Media Device" > strings/0x409/product
+ mkdir -p configs/c.1/strings/0x409
+ echo "config 1" > configs/c.1/strings/0x409/configuration
+ mkdir -p functions/mass_storage.usb0
+ ln -s functions/mass_storage.usb0 configs/c.1
+ echo 1 > functions/mass_storage.usb0/lun.0/removable
+ echo 1 > functions/mass_storage.usb0/lun.0/ro
+ echo 0 > functions/mass_storage.usb0/lun.0/cdrom
+ echo $nbd_device > functions/mass_storage.usb0/lun.0/file
+ echo "1e6a0000.usb-vhub:p4" > UDC
+ )
+ ;;
+stop)
+ (
+ cd $gadget_dir
+ rm configs/c.1/mass_storage.usb0
+ rmdir functions/mass_storage.usb0
+ rmdir configs/c.1/strings/0x409
+ rmdir configs/c.1
+ rmdir strings/0x409
+ )
+ rmdir $gadget_dir
+ ;;
+*)
+ echo "invalid action $action" >&2
+ exit 1
+esac
+
+exit 0
+
diff --git a/meta-phosphor/aspeed-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend b/meta-phosphor/aspeed-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend
new file mode 100644
index 000000000..3ccc08798
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+FILES_${PN} += "${sysconfdir}/nbd-proxy/state"
+SRC_URI += "file://state_hook"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/nbd-proxy/
+ install -m 0755 ${WORKDIR}/state_hook ${D}${sysconfdir}/nbd-proxy/state
+}
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index 5981066b8..d0005629b 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -73,7 +73,7 @@ IMAGE_FEATURES += " \
obmc-software \
obmc-system-mgmt \
obmc-user-mgmt \
- ssh-server-dropbear \
+ ssh-server-openssh \
obmc-debug-collector \
obmc-network-mgmt \
obmc-settings-mgmt \
diff --git a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
index f9195476d..b31e3885e 100644
--- a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
+++ b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
@@ -14,8 +14,8 @@ RDEPENDS_${PN} += "nbd-client"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/jsnbd"
-SRCREV = "d5b9857609401e3cf9c53b111134a6aab8e4573c"
+SRC_URI = "git://scm.raptorcs.com/scm/git/jsnbd;protocol=https"
+SRCREV = "bcc6cc5bcadb20005ae03c8c4a4eb87006f0d222"
NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
diff --git a/meta-phosphor/recipes-graphics/obmc-ikvm/obmc-ikvm_git.bb b/meta-phosphor/recipes-graphics/obmc-ikvm/obmc-ikvm_git.bb
index 65bfc12c5..2ce544a00 100644
--- a/meta-phosphor/recipes-graphics/obmc-ikvm/obmc-ikvm_git.bb
+++ b/meta-phosphor/recipes-graphics/obmc-ikvm/obmc-ikvm_git.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=75859989545e37968a99b631ef42722e"
DEPENDS = " libvncserver systemd sdbusplus phosphor-logging phosphor-dbus-interfaces"
-SRC_URI = "git://github.com/openbmc/obmc-ikvm"
-SRCREV = "63c3ea18c3ad560fb30d952e37a084c9d730b78a"
+SRC_URI = "git://scm.raptorcs.com/scm/git/obmc-ikvm;protocol=https"
+SRCREV = "861337e8ec92767c4c88237ec5db494a2a67fa8d"
PV = "1.0+git${SRCPV}"
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console/obmc-console-ssh@.service b/meta-phosphor/recipes-phosphor/console/obmc-console/obmc-console-ssh@.service
index 82ffe7919..6fa97466a 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console/obmc-console-ssh@.service
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console/obmc-console-ssh@.service
@@ -1,12 +1,14 @@
[Unit]
Description=Phosphor Host Console SSH Per-Connection
Wants=obmc-console@{OBMC_CONSOLE_HOST_TTY}.service
+Wants=sshdgenkeys.service
[Service]
-Environment="DROPBEAR_RSAKEY_DIR=/etc/dropbear"
-EnvironmentFile={envfiledir}/dropbear
-ExecStart=-/usr/bin/env dropbear -i -r ${{DROPBEAR_RSAKEY_DIR}}/dropbear_rsa_host_key -c "/usr/bin/env obmc-console-client" $DROPBEAR_EXTRA_ARGS
-SyslogIdentifier=dropbear
-ExecReload={base_bindir}/kill -HUP $MAINPID
+Environment="SSHD_OPTS="
+EnvironmentFile=-/etc/default/ssh
+ExecStart=-@SBINDIR@/sshd -i -o ForceCommand="/usr/bin/env obmc-console-client"
+SyslogIdentifier=sshd
+ExecReload=@BASE_BINDIR@/kill -HUP $MAINPID
StandardInput=socket
+StandardError=syslog
KillMode=process
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
index 12aacdf4c..410547f4b 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -6,14 +6,15 @@ PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit flto-automake pkgconfig
+inherit autotools pkgconfig
inherit phosphor-pid-control
inherit obmc-phosphor-ipmiprovider-symlink
+inherit systemd
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
-SRCREV = "ce6a3f36cedc2f822fb446bc5094eaeab47eb4af"
+SRC_URI = "git://scm.raptorcs.com/scm/git/phosphor-pid-control;protocol=https"
+SRCREV = "3660b3888af789266b6c84714b4e161a32e6ea54"
# Each platform will need a service file that starts
# at an appropriate time per system. For instance, if
@@ -24,7 +25,6 @@ DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbusplus"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "phosphor-logging"
-DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "libevdev"
DEPENDS += "nlohmann-json"
DEPENDS += "cli11"
@@ -33,6 +33,14 @@ DEPENDS += "boost"
# We depend on this to be built first so we can build our providers.
DEPENDS += "phosphor-ipmi-host"
+SERVICE_FILE = "phosphor-pid-control.service"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}"
+
+EXTRA_OECONF = " \
+ SYSTEMD_TARGET="multi-user.target" \
+ "
+
FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor"
# The following installs the OEM IPMI handler for the fan controls.
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh b/meta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh
index 278cd41d7..c342e504d 100755
--- a/meta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh
@@ -232,6 +232,14 @@ done
if test -n "$doflash"
then
+ mkdir -p /var/lock
+
+ BMC_MAC_ADDRESS=$(fw_printenv -n ethaddr)
+ if test -n "$BMC_MAC_ADDRESS"
+ then
+ echo "Detected RCS BMC MAC address $BMC_MAC_ADDRESS"
+ fi
+
for f in $imglist
do
if test ! -s $f
@@ -240,6 +248,29 @@ then
rm $f
continue
fi
+
+ UPDATE_IMAGE_MAC=0
+ if test -n "$BMC_MAC_ADDRESS"
+ then
+ if test "${f#$image}" = "bmc"
+ then
+ UPDATE_IMAGE_MAC=1
+ fi
+ if test "${f#$image}" = "u-boot"
+ then
+ UPDATE_IMAGE_MAC=1
+ fi
+ fi
+
+ if test $UPDATE_IMAGE_MAC -eq 1
+ then
+ echo "Restoring RCS BMC MAC address..."
+ bbe -e "s/rptaddr=01:23:45:67:89:ab/ethaddr=${BMC_MAC_ADDRESS}/" -o /run/initramfs/${f#$image}.modified $f
+ rm $f
+ bbe -e "s/rpt1addr=01:23:45:67:89:ab/eth1addr=${BMC_MAC_ADDRESS}/" -o $f /run/initramfs/${f#$image}.modified
+ rm /run/initramfs/${f#$image}.modified
+ fi
+
m=$(findmtd ${f#$image})
echo "Updating ${f#$image}..."
flashcp -v $f /dev/$m && rm $f
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/files/whitelist b/meta-phosphor/recipes-phosphor/initrdscripts/files/whitelist
index 20f1ec2a6..3dfc7a40f 100644
--- a/meta-phosphor/recipes-phosphor/initrdscripts/files/whitelist
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/files/whitelist
@@ -6,6 +6,11 @@
/etc/resolv.conf
/etc/shadow
/etc/systemd/network
+/etc/ssh/ssh_host_ecdsa_key
+/etc/ssh/ssh_host_ecdsa_key.pub
+/etc/ssh/ssh_host_ed25519_key
+/etc/ssh/ssh_host_ed25519_key.pub
+/etc/ssh/ssh_host_rsa_key
/var/cache/obmc
/var/lib/obmc
/var/lib/phosphor-inventory-manager
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb b/meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb
index ab2c38e90..be18a7cb1 100644
--- a/meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb
@@ -5,7 +5,10 @@ LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d71
PR = "r1"
-inherit allarch
+INSANE_SKIP_${PN} += "already-stripped"
+
+DEPENDS += "${@d.getVar('PREFERRED_PROVIDER_u-boot', True) or 'u-boot'}"
+DEPENDS += "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"
RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_base-utils}"
@@ -29,7 +32,14 @@ do_install() {
install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
install -d ${D}/dev
mknod -m 622 ${D}/dev/console c 5 1
+
+ install -d ${D}/etc
+ install -m 0644 ${STAGING_DIR}/fw_env.config ${D}/etc/fw_env.config
+ install -d ${D}/bin
+ install -m 0755 ${STAGING_DIR}/bin/fw_printenv ${D}/bin/fw_printenv
+ install -m 0755 ${STAGING_DIR}/bin/bbe ${D}/bin/bbe
}
FILES_${PN} += " /init /shutdown /update /whitelist /dev "
FILES_${PN} += " /init-options /init-download-url "
+FILES_${PN} += " /bin/fw_printenv /bin/bbe "
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb/0001-Increase-request-limit.patch b/meta-phosphor/recipes-phosphor/interfaces/bmcweb/0001-Increase-request-limit.patch
new file mode 100644
index 000000000..ce710cbfd
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb/0001-Increase-request-limit.patch
@@ -0,0 +1,15 @@
+diff --git a/crow/include/crow/http_connection.h b/crow/include/crow/http_connection.h
+index 6f44186..6c23b63 100644
+--- a/crow/include/crow/http_connection.h
++++ b/crow/include/crow/http_connection.h
+@@ -241,8 +241,8 @@ typename std::enable_if<(N > 0)>::type
+ static std::atomic<int> connectionCount;
+ #endif
+
+-// request body limit size: 30M
+-constexpr unsigned int httpReqBodyLimit = 1024 * 1024 * 30;
++// request body limit size: 128M
++constexpr unsigned int httpReqBodyLimit = 1024 * 1024 * 128;
+
+ template <typename Adaptor, typename Handler, typename... Middlewares>
+ class Connection
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index 3fd1f4e35..e6f50e12f 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -12,10 +12,12 @@ GROUPMEMS_PARAM_${PN} = "-g web -a root; -g redfish -a root"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
-SRC_URI = "git://github.com/openbmc/bmcweb.git"
+SRC_URI = "git://scm.raptorcs.com/scm/git/bmcweb;protocol=https \
+ file://0001-Increase-request-limit.patch \
+ "
PV = "1.0+git${SRCPV}"
-SRCREV = "4418c7f0ddcc5d3518831729a380a0b67e5d4093"
+SRCREV = "1bfbe0e0372de7991bab9bb0a7ba015356f7d3b2"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb b/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb
index d08dfdc40..ea4f76b3d 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb
@@ -11,5 +11,5 @@ inherit autotools pkgconfig
DEPENDS += "autoconf-archive-native"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/ipmi-blob-tool"
-SRCREV = "06561460bded9bf42398d987ac87bcec170740aa"
+SRC_URI = "git://scm.raptorcs.com/scm/git/ipmi-blob-tool;protocol=https"
+SRCREV = "00f39b84037a840a1b169a8017be75ac6636cb6f"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
index 58ef897a0..b87933fb9 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
@@ -15,8 +15,8 @@ DEPENDS += "phosphor-logging"
DEPENDS += "ipmi-blob-tool"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs"
-SRCREV = "924bc380c47f33689a1243b2d79cb619674c86fa"
+SRC_URI = "git://scm.raptorcs.com/scm/git/phosphor-ipmi-blobs;protocol=https"
+SRCREV = "9cd8f76d3a786645ba6e21e146f66f5f27a6290c"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index 8b3b6ccc9..e2d4da536 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -2,25 +2,68 @@ HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
PR = "r1"
-PV = "0.1+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit autotools pkgconfig
inherit obmc-phosphor-ipmiprovider-symlink
+inherit systemd
DEPENDS += "autoconf-archive-native"
DEPENDS += "phosphor-ipmi-blobs"
DEPENDS += "phosphor-logging"
DEPENDS += "sdbusplus"
+DEPENDS += "systemd"
DEPENDS += "ipmi-blob-tool"
+DEPENDS += "pciutils"
+
+PACKAGECONFIG ?= "cleanup-delete"
+PACKAGECONFIG[cleanup-delete] = "--enable-cleanup-delete, --disable-cleanup-delete"
+# If using static-layout, reboot-update is a good option to handle updating.
+# To be able to track the update status, update-status option can be used.
+# Note that both reboot-update and update-status cannot be enabled at the same time.
+PACKAGECONFIG[reboot-update] = "--enable-reboot-update, --disable-reboot-update"
+PACKAGECONFIG[update-status] = "--enable-update-status, --disable-update-status"
+
+# Default options for supporting various flash types:
+PACKAGECONFIG[static-bmc] = "--enable-static-layout, --disable-static-layout"
+PACKAGECONFIG[ubitar-bmc] = "--enable-tarball-ubi, --disable-tarball-ubi"
+PACKAGECONFIG[host-bios] = "--enable-host-bios, --disable-host-bios"
+
+# Hardware options to enable transmitting the data from the host.
+PACKAGECONFIG[aspeed-p2a] = "--enable-aspeed-p2a, --disable-aspeed-p2a"
+PACKAGECONFIG[aspeed-lpc] = "--enable-aspeed-lpc, --disable-aspeed-lpc"
+PACKAGECONFIG[nuvoton-lpc] = "--enable-nuvoton-lpc, --disable-nuvoton-lpc"
+PACKAGECONFIG[net-bridge] = "--enable-net-bridge, --disable-net-bridge"
+
+EXTRA_OECONF = "--disable-tests --disable-build-host-tool"
+
+# Set this variable in your recipe to set it instead of using MAPPED_ADDRESS directly.
+IPMI_FLASH_BMC_ADDRESS ?= "0"
+EXTRA_OECONF_append = " MAPPED_ADDRESS=${IPMI_FLASH_BMC_ADDRESS}"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
-SRCREV = "4679e50a5e19157b6bb4e4760a9fb92577ad37f5"
+SRC_URI = "git://scm.raptorcs.com/scm/git/phosphor-ipmi-flash;protocol=https"
+SRCREV = "79fc7c0680ebb0d5399eab83230b3d047dc8eb82"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} += "phosphor-ipmi-flash-bmc-prepare.target \
+ phosphor-ipmi-flash-bmc-verify.target \
+ phosphor-ipmi-flash-bmc-update.target"
+
+# If they enabled host-bios, add those three extra targets.
+HOST_BIOS_TARGETS = "phosphor-ipmi-flash-bios-prepare.target \
+ phosphor-ipmi-flash-bios-verify.target \
+ phosphor-ipmi-flash-bios-update.target"
+
+SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'host-bios', '${HOST_BIOS_TARGETS}', '', d)}"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"
+BLOBIPMI_PROVIDER_LIBRARY += "${@bb.utils.contains('PACKAGECONFIG', 'cleanup-delete', 'libfirmwarecleanupblob.so', '', d)}"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc
index 446008a9e..2b0977a63 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "http://github.com/openbmc/phosphor-host-ipmid"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
SRC_URI += "git://scm.raptorcs.com/scm/git/phosphor-host-ipmid;protocol=https"
-SRCREV = "f442e119aed2dc87f320bf230ad39e7dc5c72524"
+SRCREV = "5d06cc6dfee3aa0c42bb181dd7e050f4f8f8dd1e"
diff --git a/meta-phosphor/recipes-phosphor/state/files/phosphor-reset-host-reboot-attempts@.service b/meta-phosphor/recipes-phosphor/state/files/phosphor-reset-host-reboot-attempts@.service
index 35de4304b..934ebaef5 100644
--- a/meta-phosphor/recipes-phosphor/state/files/phosphor-reset-host-reboot-attempts@.service
+++ b/meta-phosphor/recipes-phosphor/state/files/phosphor-reset-host-reboot-attempts@.service
@@ -7,7 +7,7 @@ ConditionPathExists=!/run/openbmc/host@%i-on
[Service]
Restart=no
Type=oneshot
-ExecStart=/bin/sh -c "busctl set-property `mapper get-service /xyz/openbmc_project/state/host%i` /xyz/openbmc_project/state/host%i xyz.openbmc_project.Control.Boot.RebootAttempts AttemptsLeft u 3"
+ExecStart=/bin/sh -c "busctl set-property `mapper get-service /xyz/openbmc_project/state/host%i` /xyz/openbmc_project/state/host%i xyz.openbmc_project.Control.Boot.RebootAttempts AttemptsLeft u 4"
[Install]
WantedBy=obmc-host-start@%i.target
diff --git a/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb b/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
index 512a66819..231c13a61 100644
--- a/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
@@ -5,8 +5,8 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-SRC_URI = "git://github.com/openbmc/phosphor-webui.git"
-SRCREV = "4733a11b42fca6013e3957bf0e345d0cea086d96"
+SRC_URI = "git://scm.raptorcs.com/scm/git/phosphor-webui;protocol=https"
+SRCREV = "44da471fceb3790b49a43bc023781f62b19f9fde"
S = "${WORKDIR}/git"
DEPENDS_prepend = "nodejs-native "
OpenPOWER on IntegriCloud