summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bb15
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-events-config/events.yaml2
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb2
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bb
new file mode 100644
index 000000000..740b194ad
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Phosphor zone events definition default data"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-fan
+
+SRC_URI += "file://events.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${control_datadir}
+ install -D events.yaml ${DEST}/events.yaml
+}
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-events-config/events.yaml b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-events-config/events.yaml
new file mode 100644
index 000000000..b89d1dca7
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-events-config/events.yaml
@@ -0,0 +1,2 @@
+#Default zone events definition YAML - empty.
+#For format, see documentation in fan control code repository example yaml.
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
index 04413e94d..e7a6d7eca 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
@@ -58,10 +58,12 @@ SYSTEMD_LINK_${PN}-presence-tach += "${@compose_list(d, 'FMT_TACH', 'OBMC_CHASSI
PACKAGECONFIG[control] = "--enable-control \
FAN_DEF_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/fans.yaml \
FAN_ZONE_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/zones.yaml \
+ ZONE_EVENTS_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/events.yaml \
FAN_ZONE_OUTPUT_DIR=${S}/control, \
--disable-control, \
virtual/phosphor-fan-control-fan-config \
phosphor-fan-control-zone-config-native \
+ phosphor-fan-control-events-config-native \
, \
"
OpenPOWER on IntegriCloud