summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-core/os-release/os-release.bbappend4
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/dbus/obmc-rest.bb11
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/network/network.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb4
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/pyphosphor.bb15
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb2
-rw-r--r--meta-phosphor/conf/machine/include/obmc-bsp-common.inc1
11 files changed, 32 insertions, 15 deletions
diff --git a/meta-phosphor/common/recipes-core/os-release/os-release.bbappend b/meta-phosphor/common/recipes-core/os-release/os-release.bbappend
index b112c50d9..3dd203b19 100644
--- a/meta-phosphor/common/recipes-core/os-release/os-release.bbappend
+++ b/meta-phosphor/common/recipes-core/os-release/os-release.bbappend
@@ -6,11 +6,11 @@ def run_git(d, cmd):
pass
python() {
- version_id = run_git(d, 'describe --abbrev=0')
+ version_id = run_git(d, 'describe --dirty')
if version_id:
d.setVar('VERSION_ID', version_id)
- build_id = run_git(d, 'describe --dirty')
+ build_id = run_git(d, 'describe --abbrev=0')
if build_id:
d.setVar('BUILD_ID', build_id)
}
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
index 2e2c9ce87..24cde9f87 100644
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
@@ -10,7 +10,7 @@ SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
LINUX_VERSION ?= "4.4"
LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
-SRCREV="openbmc-20160329-2"
+SRCREV="openbmc-20160511-1"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb b/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
index ab6dc98f7..2472917b2 100644
--- a/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
+++ b/meta-phosphor/common/recipes-phosphor/dbus/obmc-mapper.bb
@@ -18,6 +18,6 @@ RDEPENDS_${PN} += " \
"
SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
-SRCREV = "956dd44fe5c8377ec90cef393f65033d59e082b0"
+SRCREV = "2abc4d068cec75aa3893af8197108d29ff6f1bb4"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/dbus/obmc-rest.bb b/meta-phosphor/common/recipes-phosphor/dbus/obmc-rest.bb
index f66dd26e6..af695785b 100644
--- a/meta-phosphor/common/recipes-phosphor/dbus/obmc-rest.bb
+++ b/meta-phosphor/common/recipes-phosphor/dbus/obmc-rest.bb
@@ -13,13 +13,14 @@ RDEPENDS_${PN} += " \
python-xml \
python-dbus \
python-pygobject \
- obmc-mapper \
- python-rocket \
- python-bottle \
- python-spwd \
+ obmc-mapper \
+ python-rocket \
+ python-bottle \
+ python-spwd \
+ pyphosphor \
"
SRC_URI += "git://github.com/openbmc/phosphor-rest-server"
-SRCREV = "fe90e0c579edbc19699e5aa7abbe4dd29b4dd112"
+SRCREV = "b41507f3b9c9a79ccd0ef6f48ac839b306a604b7"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
index ba1eaaf97..432007c17 100644
--- a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
@@ -19,7 +19,7 @@ RDEPENDS_${PN} += "settings"
RDEPENDS_${PN} += "network"
SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid"
-SRCREV = "b7e01a16951e868b076f3d68ecb0688a5209aa5b"
+SRCREV = "eee949f14d921d84497f41df84ab7ae45a0d830d"
S = "${WORKDIR}/git"
INSTALL_NAME = "ipmid"
diff --git a/meta-phosphor/common/recipes-phosphor/network/network.bb b/meta-phosphor/common/recipes-phosphor/network/network.bb
index 1c48c0547..1e7d84e58 100644
--- a/meta-phosphor/common/recipes-phosphor/network/network.bb
+++ b/meta-phosphor/common/recipes-phosphor/network/network.bb
@@ -10,7 +10,7 @@ RDEPENDS_${PN} += "python-dbus python-pygobject"
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
-SRCREV = "448e8d839d37532d2667b9a38bb3aadb6c804e2e"
+SRCREV = "682512485947977a8d130a1cf9832b12583ea253"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
index 5ce5818c5..4b9f60eb9 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
@@ -13,7 +13,7 @@ TARGET_CPPFLAGS += "-std=c++11 -fpic"
SRC_URI += "git://github.com/openbmc/phosphor-event"
-SRCREV = "127c8cf513ba9ed6bcc460fbea29b36eb8d23bac"
+SRCREV = "0396126c2d816529d57cee2b413727eb78f7cef3"
RDEPENDS_${PN} += "libsystemd"
DEPENDS += "systemd"
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb b/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
index fa551f553..bf25caeb3 100644
--- a/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
@@ -13,7 +13,7 @@ RDEPENDS_${PN} += " \
python-json \
python-dbus \
python-xml \
- obmc-mapper \
+ pyphosphor \
"
SRC_URI += " \
@@ -21,6 +21,6 @@ SRC_URI += " \
file://rest-dbus.service \
"
-SRCREV = "b10a57e2f34e94b13697328cc22f876f738feb0e"
+SRCREV = "c693ba1126dcb493058d4ebeb4604b71e3bb3f08"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/pyphosphor.bb b/meta-phosphor/common/recipes-phosphor/skeleton/pyphosphor.bb
new file mode 100644
index 000000000..a44f19a6a
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/pyphosphor.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Phosphor python library"
+DESCRIPTION = "Phosphor python library."
+HOMEPAGE = "http://github.com/openbmc/pyobmc"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit allarch
+inherit setuptools
+
+SRC_URI += "git://github.com/openbmc/pyphosphor"
+
+SRCREV = "1b3c05c1f44185f8176f46829a26ad6e50d0831f"
+
+S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
index 551843eab..155331417 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
@@ -20,7 +20,7 @@ SRC_URI += "git://github.com/openbmc/skeleton"
PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}"
PACKAGECONFIG[openpower-pflash] = ",,,pflash"
-SRCREV = "27ca44ad1a96f90d42dcb50183700e5ca5358642"
+SRCREV = "264009617c231447d6c8fc61264cf3c6ea7f49d5"
S = "${WORKDIR}"
diff --git a/meta-phosphor/conf/machine/include/obmc-bsp-common.inc b/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
index 60ed0888a..260cc90a3 100644
--- a/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
+++ b/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
@@ -14,6 +14,7 @@ UBOOT_SUFFIX ?= "bin"
MACHINEOVERRIDES =. "openbmc:"
IMAGE_FSTYPES += "overlay"
+IMAGE_FSTYPES += "cpio.${INITRAMFS_CTYPE}.u-boot"
IMAGE_INSTALL += "u-boot-fw-utils"
IMAGE_CLASSES += "obmc-phosphor-image_types_uboot"
OpenPOWER on IntegriCloud