summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd/default.network4
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend9
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-config.cfg8
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-patches.scc8
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.cfg3
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.scc17
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb12
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid-oem.bb31
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb8
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb10
-rw-r--r--meta-phosphor/conf/machine/include/sample.inc3
11 files changed, 61 insertions, 52 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd/default.network b/meta-phosphor/common/recipes-core/systemd/systemd/default.network
new file mode 100644
index 000000000..c75c3d60d
--- /dev/null
+++ b/meta-phosphor/common/recipes-core/systemd/systemd/default.network
@@ -0,0 +1,4 @@
+[Match]
+Name=eth*
+[Network]
+DHCP=ipv4
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 000000000..680595cb4
--- /dev/null
+++ b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,9 @@
+PACKAGECONFIG += "networkd"
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+SRC_URI += "file://default.network"
+
+FILES_${PN} += "${libdir}/systemd/network/default.network"
+
+do_install_append() {
+ install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
+}
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-config.cfg b/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-config.cfg
deleted file mode 100644
index 17c8b503d..000000000
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-config.cfg
+++ /dev/null
@@ -1,8 +0,0 @@
-#
-# Used by yocto-kernel to manage config options.
-#
-# yocto-kernel may change the contents of this file in any
-# way it sees fit, including removing comments like this,
-# so don't manually make any modifications you don't want
-# to lose.
-#
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-patches.scc b/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-patches.scc
deleted file mode 100644
index 7a598d911..000000000
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp-user-patches.scc
+++ /dev/null
@@ -1,8 +0,0 @@
-#
-# Used by yocto-kernel to manage patches.
-#
-# yocto-kernel may change the contents of this file in any
-# way it sees fit, including removing comments like this,
-# so don't manually make any modifications you don't want
-# to lose.
-#
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.cfg b/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.cfg
deleted file mode 100644
index 95170b12e..000000000
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.cfg
+++ /dev/null
@@ -1,3 +0,0 @@
-#
-# A convenient place to add config options, nothing more.
-#
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.scc b/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.scc
deleted file mode 100644
index 88e76e649..000000000
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc/obmc-bsp.scc
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# The top-level 'feature' for the meta-obmc-bsp custom kernel.
-#
-# Essentially this is a convenient top-level container or starting
-# point for adding lower-level config fragements and features.
-#
-
-# meta-obmc-bsp.cfg in the linux-yocto-custom subdir is just a
-# convenient place for adding random config fragments.
-
-kconf hardware obmc-bsp.cfg
-
-# These are used by yocto-kernel to add config fragments and features.
-# Don't remove if you plan on using yocto-kernel with this BSP.
-
-kconf hardware obmc-bsp-user-config.cfg
-include obmc-bsp-user-patches.scc
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
index 81edb70c0..f49b3fcce 100644
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.2.bb
@@ -3,16 +3,12 @@ SECTION = "kernel"
LICENSE = "GPLv2"
KBRANCH ?= "dev"
+KCONFIG_MODE="--alldefconfig"
SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
-SRC_URI += "file://obmc-bsp.scc \
- file://obmc-bsp.cfg \
- file://obmc-bsp-user-config.cfg \
- file://obmc-bsp-user-patches.scc \
- "
LINUX_VERSION ?= "4.2"
-LINUX_VERSION_EXTENSION ?= "-openbmc-${SRCPV}"
+LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
SRCREV="openbmc-20151028-1"
@@ -22,7 +18,3 @@ COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
-
-do_configure_prepend() {
- sed -i 's/CONFIG_LOCALVERSION=.\+/CONFIG_LOCALVERSION=${LINUX_VERSION_EXTENSION}/' ${S}/arch/${ARCH}/configs/${KMACHINE}_defconfig
-}
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid-oem.bb b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid-oem.bb
new file mode 100644
index 000000000..623d7d26d
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid-oem.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
+DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
+HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
+PR = "r1"
+
+RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
+
+inherit obmc-phosphor-license
+
+DEPENDS += "systemd \
+ host-ipmid \
+ "
+
+
+RDEPENDS_${PN} += "libsystemd"
+
+
+
+SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
+
+SRCREV = "f79a21f3c1e5209f3c911399c3b822ae93bb973d"
+
+FILES_${PN} += "${libdir}/host-ipmid/*.so"
+FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -m 0755 -d ${D}${libdir}/host-ipmid
+ install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
+}
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
index ab3a1cb8c..74dad627c 100644
--- a/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/host-ipmid.bb
@@ -3,7 +3,10 @@ DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
HOMEPAGE = "http://github.com/openbmc/phosphor-host-ipmid"
PR = "r1"
-RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
+RRECOMMENDS_${PN} += "virtual/obmc-phosphor-host-ipmi-hw"
+
+RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-phosphor-ipmi-parsers}"
+
inherit obmc-phosphor-license
inherit obmc-phosphor-sdbus-service
@@ -11,7 +14,8 @@ inherit obmc-phosphor-c-daemon
SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid"
-SRCREV = "98900a99254cd177c8308b63c341f793d2ac119d"
+SRCREV = "84a5a0a8fdb2a5df9e33ab9132f2c083eaa4b756"
+
S = "${WORKDIR}/git"
INSTALL_NAME = "ipmid"
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
index 0c8687c92..572030c53 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/skeleton.bb
@@ -17,20 +17,22 @@ DEPENDS += "glib-2.0"
RDEPENDS_${PN} += "python-subprocess python-tftpy"
SRC_URI += "git://github.com/openbmc/skeleton"
-SRCREV = "47750bc1c06aebda189f2e8d7862c9d9b9ffe35b"
+SRCREV = "597d49e68e8bf0ddedb2e01cbd3fb500ee1c22e3"
S = "${WORKDIR}"
do_compile() {
- oe_runmake -C git all
+ oe_runmake -C git
}
do_install() {
source=${S}/git
install -d ${D}/${sbindir} ${D}${libdir}
- for i in ${source}/bin/*.py ${source}/bin/*.exe; do
+ for i in ${source}/bin/*; do
install $i ${D}/${sbindir}
done
- install ${source}/bin/libopenbmc_intf.so ${D}/${libdir}
+ for i in ${source}/lib/*; do
+ install $i ${D}/${libdir}
+ done
}
diff --git a/meta-phosphor/conf/machine/include/sample.inc b/meta-phosphor/conf/machine/include/sample.inc
index 16e29801f..2b8f98689 100644
--- a/meta-phosphor/conf/machine/include/sample.inc
+++ b/meta-phosphor/conf/machine/include/sample.inc
@@ -17,6 +17,9 @@ VIRTUAL-RUNTIME_obmc-phosphor-chassis-ctl = " \
VIRTUAL-RUNTIME_obmc-phosphor-flash-ctl = " \
obmc-phosphor-example-pydbus \
"
+VIRTUAL-RUNTIME_obmc-phosphor-ipmi-parsers = " \
+ host-ipmid-oem \
+ "
PREFERRED_PROVIDER_virtual/obmc-phosphor-host-ipmi-hw ?= "host-ipmi-hw-example"
PREFERRED_PROVIDER_virtual/obmc-phosphor-chassis-mgmt = "obmc-phosphor-chassisd"
OpenPOWER on IntegriCloud