summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
new file mode 100644
index 000000000..b02b83234
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
@@ -0,0 +1,21 @@
+SUMMARY = "OpenBMC gdbus library"
+DESCRIPTION = "libopenbmc_intf provides a set of gpio access \
+methods and the GDBUS skeleton code for the org.openbmc DBUS API."
+PR = "r1"
+
+inherit skeleton
+inherit pkgconfig
+
+DEPENDS += "glib-2.0"
+DEPENDS += "cjson"
+
+SKELETON_DIR = "libopenbmc_intf"
+
+SRC_URI += "file://gpio_defs.json"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+
+ install -d ${D}${sysconfdir}/default/obmc/gpio/
+ install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
+}
OpenPOWER on IntegriCloud