summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/mrw
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/mrw')
-rw-r--r--meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb21
-rw-r--r--meta-phosphor/recipes-phosphor/mrw/mrw-native.bb20
-rw-r--r--meta-phosphor/recipes-phosphor/mrw/mrw-patch-native.bb19
-rw-r--r--meta-phosphor/recipes-phosphor/mrw/mrw-perl-tools-native.bb13
4 files changed, 73 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
new file mode 100644
index 000000000..1930388ed
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
+DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
+PR = "r1"
+
+S = "${WORKDIR}/scripts"
+
+inherit obmc-phosphor-license
+inherit native
+inherit perlnative
+inherit cpan-base
+inherit mrw-rev
+
+DEPENDS += "libxml-simple-perl-native json-perl-native"
+
+SRC_URI += "${MRW_API_SRC_URI}"
+SRCREV = "${MRW_API_SRCREV}"
+
+do_install() {
+ install -d ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
+ install -m 0755 Targets.pm ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
+}
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-native.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-native.bb
new file mode 100644
index 000000000..db9cbd902
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-native.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Phosphor OpenBMC machine readable workbook"
+DESCRIPTION = "Pulls down system specific data"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+inherit obmc-phosphor-license
+inherit obmc-xmlpatch
+inherit native
+inherit mrw-xml
+
+PHOSPHOR_MRW_URI ?= "http://missing-mrw-uri"
+SRC_URI += "${PHOSPHOR_MRW_URI}"
+SRCREV = "${PHOSPHOR_MRW_REV}"
+
+do_install() {
+ install -d ${D}/${mrw_datadir}
+ install -m 0644 ${MRW_XML} ${D}/${mrw_datadir}
+}
+
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-patch-native.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-patch-native.bb
new file mode 100644
index 000000000..acaec73aa
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-patch-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor machine readable workbook patching script"
+DESCRIPTION = "Retrieve the script that can patch the MRW XML"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+inherit obmc-phosphor-license
+inherit native
+inherit mrw-rev
+
+DEPENDS += "python-native python-lxml-native"
+
+SRC_URI += "${MRW_TOOLS_SRC_URI}"
+SRCREV = "${MRW_TOOLS_SRCREV}"
+
+do_install() {
+ install -d ${D}${bindir}/obmc-mrw
+ install -m 0755 patchxml.py ${D}${bindir}/obmc-mrw
+}
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-perl-tools-native.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-perl-tools-native.bb
new file mode 100644
index 000000000..91651227b
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-perl-tools-native.bb
@@ -0,0 +1,13 @@
+SUMMARY = "OpenBMC MRW Perl Tools"
+DESCRIPTION = "OpenBMC Perl tools for the machine readable workbook"
+S = "${WORKDIR}/git"
+
+inherit obmc-phosphor-license
+inherit native
+inherit cpan_build
+inherit mrw-rev
+
+DEPENDS += "libmodule-build-perl-native mrw-api-native yaml-tiny-native"
+
+SRC_URI += "${MRW_TOOLS_SRC_URI}"
+SRCREV = "${MRW_TOOLS_SRCREV}"
OpenPOWER on IntegriCloud