summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/initrdscripts
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/initrdscripts')
-rwxr-xr-xmeta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh11
-rw-r--r--meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb12
2 files changed, 22 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh b/meta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh
index 278cd41d7..efe47cfe8 100755
--- a/meta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/files/obmc-update.sh
@@ -232,6 +232,11 @@ done
if test -n "$doflash"
then
+ mkdir -p /var/lock
+
+ BMC_MAC_ADDRESS=$(fw_printenv -n ethaddr)
+ echo "Detected RCS BMC MAC address $BMC_MAC_ADDRESS"
+
for f in $imglist
do
if test ! -s $f
@@ -244,6 +249,12 @@ then
echo "Updating ${f#$image}..."
flashcp -v $f /dev/$m && rm $f
done
+
+ echo "Restoring RCS BMC MAC address..."
+ fw_setenv ethaddr $BMC_MAC_ADDRESS
+ fw_setenv eth1addr $BMC_MAC_ADDRESS
+ fw_setenv rptaddr
+ fw_setenv rpt1addr
fi
if test -d $save -a "x$toram" = xy
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb b/meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb
index ab2c38e90..da03cc7f9 100644
--- a/meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/obmc-phosphor-initfs.bb
@@ -5,7 +5,10 @@ LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d71
PR = "r1"
-inherit allarch
+INSANE_SKIP_${PN} += "already-stripped"
+
+DEPENDS += "${@d.getVar('PREFERRED_PROVIDER_u-boot', True) or 'u-boot'}"
+DEPENDS += "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"
RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_base-utils}"
@@ -29,7 +32,14 @@ do_install() {
install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
install -d ${D}/dev
mknod -m 622 ${D}/dev/console c 5 1
+
+ install -d ${D}/etc
+ install -m 0644 ${STAGING_DIR}/fw_env.config ${D}/etc/fw_env.config
+ install -d ${D}/bin
+ install -m 0755 ${STAGING_DIR}/bin/fw_printenv ${D}/bin/fw_printenv
+ install -m 0755 ${STAGING_DIR}/bin/fw_setenv ${D}/bin/fw_setenv
}
FILES_${PN} += " /init /shutdown /update /whitelist /dev "
FILES_${PN} += " /init-options /init-download-url "
+FILES_${PN} += " /bin/fw_printenv /bin/fw_setenv "
OpenPOWER on IntegriCloud