summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/fans/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/files/Makefile')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/files/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/files/Makefile b/meta-phosphor/recipes-phosphor/fans/files/Makefile
new file mode 100644
index 000000000..10e3fa2ae
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/fans/files/Makefile
@@ -0,0 +1,15 @@
+EXE = obmc-phosphor-fand
+OBJS = $(EXE).o
+DEPPKGS = gio-unix-2.0 glib-2.0
+CC ?= $(CROSS_COMPILE)gcc
+INCLUDES += $(shell pkg-config --cflags $(DEPPKGS))
+LIBS += $(shell pkg-config --libs $(DEPPKGS))
+
+%.o : %.c
+ $(CC) -c $^ $(CFLAGS) $(INCLUDES) -o $@
+$(EXE): $(OBJS)
+ $(CC) $^ $(LDFLAGS) $(LDFLAGS) -o $@
+clean:
+ rm -f $(OBJS) $(EXE) *.o *.d
+distclean: clean
+ rm -f *.c~ *.h~ *.sh~ Makefile~ config.mk~
OpenPOWER on IntegriCloud