summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/network/network.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/network/network.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/network/network.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/network/network.bb b/meta-phosphor/common/recipes-phosphor/network/network.bb
index 71298984c..d35f26ccc 100644
--- a/meta-phosphor/common/recipes-phosphor/network/network.bb
+++ b/meta-phosphor/common/recipes-phosphor/network/network.bb
@@ -5,17 +5,21 @@ PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
+inherit obmc-phosphor-sdbus-service
+
+SYSTEMD_SERVICE_${PN} += "network.service network-update-dns.service"
RDEPENDS_${PN} += "python-dbus python-pygobject"
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
-SRCREV = "fbf7d68e78684739ff860f20f6cbdd0932003912"
+SRCREV = "c69c3d30fd7d5fd04ba990788b6d75b19f275fc8"
S = "${WORKDIR}/git"
do_install() {
install -d ${D}/${sbindir}
install ${S}/netman.py ${D}/${sbindir}
+ install ${S}/netman_watch_dns ${D}/${sbindir}
}
OpenPOWER on IntegriCloud