summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/mrw
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/mrw')
-rw-r--r--meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
new file mode 100644
index 000000000..ec1df89a3
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
+DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
+PR = "r1"
+
+S = "${WORKDIR}/scripts"
+
+inherit obmc-phosphor-license
+inherit native
+inherit perlnative
+inherit cpan-base
+
+DEPENDS += "libxml-simple-perl-native json-perl-native"
+
+SRC_URI += "git://github.com/open-power/serverwiz.git;subpath=scripts"
+SRCREV = "04f15f37e9ab6c09412a0abcffb87e9aefcc5368"
+
+do_install() {
+ install -d ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
+ install -m 0755 Targets.pm ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
+}
OpenPOWER on IntegriCloud