summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/logging
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/logging')
-rw-r--r--meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb18
-rw-r--r--meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example/callouts.yaml1
-rw-r--r--meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb25
-rw-r--r--meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb9
4 files changed, 52 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
new file mode 100644
index 000000000..f76d202e1
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Generated callout information for phosphor-logging"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-logging
+
+SRC_URI += "file://callouts.yaml"
+
+PROVIDES += "virtual/phosphor-logging-callouts"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${callouts_datadir}
+ install -d ${DEST}
+ install callouts.yaml ${DEST}
+}
diff --git a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example/callouts.yaml b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example/callouts.yaml
new file mode 100644
index 000000000..5b92a04c4
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-example/callouts.yaml
@@ -0,0 +1 @@
+/sys/devices/device: /system/chassis/motherboard/device
diff --git a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb
new file mode 100644
index 000000000..49816260a
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Generated callout information for phosphor-logging"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-logging
+
+DEPENDS += " \
+ mrw-native \
+ mrw-perl-tools-native \
+ "
+
+PROVIDES += "virtual/phosphor-logging-callouts"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${callouts_datadir}
+ install -d ${DEST}
+
+ ${bindir}/perl-native/perl \
+ ${bindir}/gen_callouts.pl \
+ -m ${datadir}/obmc-mrw/${MACHINE}.xml \
+ -o ${DEST}/callouts.yaml
+}
diff --git a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb
index 14f2e6ebb..1d059c409 100644
--- a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb
+++ b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb
@@ -8,6 +8,7 @@ inherit pythonnative
inherit obmc-phosphor-license
inherit obmc-phosphor-dbus-service
inherit phosphor-dbus-interfaces
+inherit phosphor-logging
DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
@@ -17,6 +18,7 @@ DEPENDS += "python-mako-native"
DEPENDS += "python-pyyaml-native"
DEPENDS += "sdbusplus sdbusplus-native"
DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "virtual/phosphor-logging-callouts"
RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
PROVIDES += "virtual/obmc-logging-mgmt"
RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
@@ -26,4 +28,9 @@ SRCREV = "9cfe9f38d9ed2ddedea6d58040bed6bfc0831f08"
S = "${WORKDIR}/git"
-EXTRA_OECONF = "YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir}"
+EXTRA_OECONF = " \
+ YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
+ CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
+ "
+
+TARGET_CXXFLAGS += "-DPROCESS_META"
OpenPOWER on IntegriCloud