summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-devtools')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-gevent/0002-gevent-eat-ssl-self-cert-errors.patch13
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend2
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-gevent/0002-gevent-eat-ssl-self-cert-errors.patch b/meta-phosphor/common/recipes-devtools/python/python-gevent/0002-gevent-eat-ssl-self-cert-errors.patch
new file mode 100644
index 000000000..36990e851
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-gevent/0002-gevent-eat-ssl-self-cert-errors.patch
@@ -0,0 +1,13 @@
+--- a/gevent/ssl.py 2016-11-02 13:17:37.917401795 -0500
++++ b/gevent/newssl.py 2016-11-02 13:17:23.085401962 -0500
+@@ -334,6 +334,8 @@ class SSLSocket(socket):
+ raise
+ sys.exc_clear()
+ self._wait(self._write_event, timeout_exc=_SSLErrorHandshakeTimeout)
++ elif ex.reason in ['SSLV3_ALERT_CERTIFICATE_EXPIRED', 'TLSV1_ALERT_UNKNOWN_CA']:
++ return None
+ else:
+ raise
+
+ def connect(self, addr):
+ """Connects to remote ADDR, and then wraps the connection in
diff --git a/meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend b/meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend
index 00a7c0d4a..4dd9786de 100644
--- a/meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend
+++ b/meta-phosphor/common/recipes-devtools/python/python-gevent_%.bbappend
@@ -1,4 +1,4 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://libev-config-guess.patch"
SRC_URI += "file://0001-gevent-py279-ssl-wrap.patch"
-
+SRC_URI += "file://0002-gevent-eat-ssl-self-cert-errors.patch"
OpenPOWER on IntegriCloud