summaryrefslogtreecommitdiffstats
path: root/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb')
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb
new file mode 100644
index 000000000..7ed83b3a4
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "FRU properties config for openpower-vpd-parser"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit openpower-fru-vpd
+
+SRC_URI += "file://example.yaml"
+
+PROVIDES += "virtual/openpower-fru-properties"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # This recipe is supposed to create an output yaml file with
+ # FRU property values extracted from the MRW. This example recipe
+ # provides a sample output file.
+
+ DEST=${D}${properties_datadir}
+ install -d ${DEST}
+ install example.yaml ${DEST}/out.yaml
+}
OpenPOWER on IntegriCloud