summaryrefslogtreecommitdiffstats
path: root/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb')
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
new file mode 100644
index 000000000..8f9bd050b
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Inventory config for openpower-vpd-parser"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit openpower-fru-vpd
+
+SRC_URI += "file://inventory"
+
+PROVIDES += "virtual/openpower-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # This recipe is supposed to create a systemd environment file
+ # with values for FRU types and paths. This example recipe
+ # uses a pre-defined file ($PN/inventory).
+
+ DEST=${D}${inventory_datadir_native}
+ install -d ${DEST}
+ install inventory ${DEST}
+}
OpenPOWER on IntegriCloud