summaryrefslogtreecommitdiffstats
path: root/meta-openpower/common/recipes-phosphor/host/checkstop-monitor.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/host/checkstop-monitor.bb')
-rw-r--r--meta-openpower/common/recipes-phosphor/host/checkstop-monitor.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openpower/common/recipes-phosphor/host/checkstop-monitor.bb b/meta-openpower/common/recipes-phosphor/host/checkstop-monitor.bb
new file mode 100644
index 000000000..4959a3b73
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/host/checkstop-monitor.bb
@@ -0,0 +1,30 @@
+SUMMARY = "OpenPOWER Host checkstop monitor application"
+PR = "r1"
+
+inherit obmc-phosphor-systemd
+inherit obmc-phosphor-license
+inherit allarch
+
+DEPENDS += "virtual/obmc-gpio-monitor"
+RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+
+# For now, monitoring checkstop is the only usecase
+OBMC_HOST_MONITOR_INSTANCES = "checkstop"
+
+# Copies config file having arguments for monitoring host checkstop
+# via GPIO assertion
+SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
+
+# This package is not supplying the unit file and also this is not a native
+# recipe since state-mgmt needs this package at runtime. Unsetting this below
+# variable will let the build go through
+SYSTEMD_SERVICE_${PN} ?=""
+
+# Install the override to set up a Conflicts relation
+SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
+
+STATES = "startmin"
+GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
+GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service"
+CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"
OpenPOWER on IntegriCloud