summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb
new file mode 100644
index 000000000..2ce6bdbd6
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb
@@ -0,0 +1,18 @@
+inherit setuptools3
+require python-cython.inc
+
+RDEPENDS_${PN} += "\
+ python3-setuptools \
+"
+
+# running build_ext a second time during install fails, because Python
+# would then attempt to import cythonized modules built for the target
+# architecture.
+DISTUTILS_INSTALL_ARGS += "--skip-build"
+
+do_install_append() {
+ # rename scripts that would conflict with the Python 2 build of Cython
+ mv ${D}${bindir}/cython ${D}${bindir}/cython3
+ mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
+ mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
+}
OpenPOWER on IntegriCloud