summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/meta-ibm
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf2
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb22
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map.bb18
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf2
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map-native.bb22
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map.bb18
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf2
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb23
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map.bb19
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf1
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map.bb15
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf1
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-inventory-map.bb14
13 files changed, 70 insertions, 89 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf
index 97d0bc269..d87b732ea 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf
@@ -11,4 +11,4 @@ UBOOT_LOADADDRESS = "0x40008000"
FLASH_SIZE = "32768"
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "firestone-ipmi-inventory-map"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "firestone-ipmi-inventory-map-native"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..90276695b
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Firestone IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map.bb
deleted file mode 100644
index 52ff03e79..000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Firestone IPMI to DBus Inventory mapping."
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-
-SRC_URI += "file://config.yaml"
-
-PROVIDES += "virtual/phosphor-ipmi-fru-config"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${datadir}/phosphor-ipmi-fru
-
- install -d ${DEST}
- install config.yaml ${DEST}
-}
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf
index 5653e5bde..436c68a97 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf
@@ -11,4 +11,4 @@ UBOOT_LOADADDRESS = "0x40008000"
FLASH_SIZE = "32768"
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "garrison-ipmi-inventory-map"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "garrison-ipmi-inventory-map-native"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..d119208f4
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Garrison IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map.bb
deleted file mode 100644
index 05a622fce..000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Garrison IPMI to DBus Inventory mapping."
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-
-SRC_URI += "file://config.yaml"
-
-PROVIDES += "virtual/phosphor-ipmi-fru-config"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${datadir}/phosphor-ipmi-fru
-
- install -d ${DEST}
- install config.yaml ${DEST}
-}
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
index 20cd7833f..c0c5bfb0b 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
@@ -15,4 +15,4 @@ PHOSPHOR_MRW_URI = "git://github.com/open-power/palmetto-xml"
PHOSPHOR_MRW_REV = "82818682f2c2009c30d700df6d5f8897a3096e4f"
PREFERRED_PROVIDER_virtual/obmc-inventory-data = "obmc-inventory"
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "palmetto-ipmi-inventory-map"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "palmetto-ipmi-inventory-map-native"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..2b5348a9f
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Palmetto IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
+
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map.bb
deleted file mode 100644
index b9e1fcb6b..000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Palmetto IPMI to DBus Inventory mapping."
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-
-SRC_URI += "file://config.yaml"
-
-PROVIDES += "virtual/phosphor-ipmi-fru-config"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${datadir}/phosphor-ipmi-fru
-
- install -d ${DEST}
- install config.yaml ${DEST}
-}
-
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
index 7caf5a0fe..2801ee516 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
@@ -4,7 +4,6 @@ KERNEL_DEVICETREE = "${KMACHINE}-bmc-opp-${MACHINE}.dtb"
UBOOT_MACHINE = "ast_g5_ncsi_config"
PREFERRED_PROVIDER_virtual/p9-vcs-workaround = 'cpld-trigger'
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "romulus-ipmi-inventory-map"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map.bb
deleted file mode 100644
index e581d0ba7..000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "Romulus IPMI to DBus Inventory mapping."
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-
-PROVIDES += "virtual/phosphor-ipmi-fru-config"
-
-do_install() {
- DEST=${D}${datadir}/phosphor-ipmi-fru
- install -d ${DEST}
-
- # TODO - Run an MRW script.
-}
-
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
index a93e11d60..bedb6df2c 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
@@ -6,7 +6,6 @@ UBOOT_MACHINE = "ast_g5_ncsi_config"
OBMC_MACHINE_FEATURES += "obmc-mrw"
PREFERRED_PROVIDER_virtual/p9-vcs-workaround = 'vcs-pre-post'
-PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "witherspoon-ipmi-inventory-map"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-inventory-map.bb
deleted file mode 100644
index 18ce20fc3..000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-inventory-map.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Witherspoon IPMI to DBus Inventory mapping."
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-
-PROVIDES += "virtual/phosphor-ipmi-fru-config"
-
-do_install() {
- DEST=${D}${datadir}/phosphor-ipmi-fru
- install -d ${DEST}
-
- # TODO - Run an MRW script.
-}
OpenPOWER on IntegriCloud