summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/ast-vga-disable.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/ast-vga-disable.bb')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/ast-vga-disable.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/ast-vga-disable.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/ast-vga-disable.bb
new file mode 100644
index 000000000..f2ae45fd7
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/ast-vga-disable.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Talos II VGA Disable"
+DESCRIPTION = "Talos II power on VGA disable controller"
+PR = "r0"
+
+inherit obmc-phosphor-systemd
+inherit obmc-phosphor-license
+
+PROVIDES += 'virtual/talos-ast-vga-disable'
+RPROVIDES_${PN} += 'virtual-talos-ast-vga-disable'
+
+RDEPENDS_${PN} += "bash"
+
+S = "${WORKDIR}"
+SRC_URI += "file://ast-vga-disable-check"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/ast-vga-disable-check ${D}${bindir}/ast-vga-disable-check
+}
+
+TMPL = "ast_vga_disable@.service"
+INSTFMT = "ast_vga_disable@{0}.service"
+TGTFMT = "obmc-chassis-poweron@{0}.target"
+FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
OpenPOWER on IntegriCloud