summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/common/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-bsp')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-bsp/fsidbg/fsidbg.bb18
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-bsp/iicmaster/iicmaster.bb19
2 files changed, 18 insertions, 19 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/fsidbg/fsidbg.bb b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/fsidbg/fsidbg.bb
new file mode 100644
index 000000000..b6fed556a
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/fsidbg/fsidbg.bb
@@ -0,0 +1,18 @@
+SUMMARY = "FSI debug tool"
+DESCRIPTION = "fsidbg is a tool to access remote FSI engines and perform client driver operations"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
+
+SRC_URI += "git://github.com/eddiejames/fsidbg.git"
+
+SRCREV = "dfe278065c877724242dfae15a4c627fd2e3611c"
+PV = "git${SRCREV}"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fsidbg ${D}${bindir}
+}
+
+TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/iicmaster/iicmaster.bb b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/iicmaster/iicmaster.bb
deleted file mode 100644
index 2511e45d2..000000000
--- a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/iicmaster/iicmaster.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "I2C debug tool"
-DESCRIPTION = "iicmaster provides a debug interface for remote, FSI-based I2C engines"
-LICENSE = "GPLv3"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
-
-SRC_URI += "git://github.com/eddiejames/iicmaster.git"
-
-SRCREV = "b71dbf99af495a631dc5f3564296903667bc516c"
-PV = "git${SRCREV}"
-
-S = "${WORKDIR}/git"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 iicmaster ${D}${bindir}
-}
-
-#TODO: openbmc/openbmc#1362 - Fix GNU_HASH warnings in iic2master
-TARGET_CC_ARCH += "${LDFLAGS}"
OpenPOWER on IntegriCloud