summaryrefslogtreecommitdiffstats
path: root/meta-nuvoton/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'meta-nuvoton/recipes-bsp/u-boot')
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb49
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb19
2 files changed, 68 insertions, 0 deletions
diff --git a/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb b/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
new file mode 100644
index 000000000..cefdea803
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
@@ -0,0 +1,49 @@
+SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+SECTION = "bootloader"
+DEPENDS = "mtd-utils"
+
+PROVIDES += "u-boot-fw-utils"
+
+UBRANCH = "npcm7xx"
+SRC_URI = "git://github.com/Nuvoton-Israel/u-boot.git;branch=${UBRANCH}"
+SRCREV = "196461383f7d043f18cab3bb34dded89fba4712a"
+
+PV .= "+${UBRANCH}+"
+
+S = "${WORKDIR}/git"
+
+INSANE_SKIP_${PN} = "already-stripped"
+
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" HOSTCC="${BUILD_CC} ${BUILD_FLAGS} ${BUILD_LDFLAGS}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -d ${D}${sysconfdir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
+}
+
+do_install_class-cross () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
+uboot_fw_utils_cross() {
+ sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+BBCLASSEXTEND = "cross"
diff --git a/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb b/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb
new file mode 100644
index 000000000..ea1fdbebe
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "U-boot for Nuvoton NPCM7xx Baseboard Management Controller"
+
+require recipes-bsp/u-boot/u-boot.inc
+
+PROVIDES += "u-boot"
+
+DEPENDS += "dtc-native"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+
+S = "${WORKDIR}/git"
+
+UBRANCH = "npcm7xx"
+SRC_URI = "git://github.com/Nuvoton-Israel/u-boot.git;branch=${UBRANCH}"
+SRCREV = "196461383f7d043f18cab3bb34dded89fba4712a"
+
+PV .= "+${UBRANCH}+"
+
OpenPOWER on IntegriCloud