summaryrefslogtreecommitdiffstats
path: root/meta-intel/meta-common
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel/meta-common')
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb11
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb34
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend1
3 files changed, 46 insertions, 0 deletions
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
new file mode 100644
index 000000000..ce95082ce
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
@@ -0,0 +1,11 @@
+SUMMARY="Add /com/intel namespace to phosphor-mapper"
+DESCRIPTION="Add the /com/intel path namespace and \
+com.intel interface prefix to the mapper watch list."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit phosphor-mapper
+inherit native
+
+PHOSPHOR_MAPPER_SERVICE_append = " com.intel"
+PHOSPHOR_MAPPER_INTERFACE_append = " com.intel"
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
new file mode 100644
index 000000000..14214e017
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Intel DBus Interfaces"
+DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit pythonnative
+inherit phosphor-dbus-yaml
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbus++-native"
+
+SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
+SRCREV = "299018f99693771c175980315a3ee54f7abd7303"
+
+DEPENDS_remove_class-native = "sdbus++-native"
+DEPENDS_remove_class-nativesdk = "sdbus++-native"
+
+PACKAGECONFIG ??= "libintel_dbus"
+PACKAGECONFIG[libintel_dbus] = " \
+ --enable-libintel_dbus, \
+ --disable-libintel_dbus, \
+ systemd sdbusplus, \
+ libsystemd sdbusplus \
+ "
+
+PACKAGECONFIG_remove_class-native = "libintel_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
+
+BBCLASSEXTEND += "native nativesdk" \ No newline at end of file
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend b/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
new file mode 100644
index 000000000..435531878
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
@@ -0,0 +1 @@
+PHOSPHOR_MAPPER_CONFIGS_append = " intel-dbus-interfaces-mapper-config-native"
OpenPOWER on IntegriCloud