summaryrefslogtreecommitdiffstats
path: root/meta-intel/meta-common
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel/meta-common')
-rw-r--r--meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend9
-rw-r--r--meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb1
-rw-r--r--meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend1
-rw-r--r--meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb19
-rwxr-xr-xmeta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml36
5 files changed, 66 insertions, 0 deletions
diff --git a/meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend b/meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend
new file mode 100644
index 000000000..3fe1c3f38
--- /dev/null
+++ b/meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend
@@ -0,0 +1,9 @@
+# Remove these files since they are provided by obmc-intel-targets
+SYSTEMD_SERVICE_${PN}_remove += " obmc-host-start@.target"
+SYSTEMD_SERVICE_${PN}_remove += " obmc-host-stop@.target"
+SYSTEMD_SERVICE_${PN}_remove += " obmc-host-reboot@.target"
+SYSTEMD_SERVICE_${PN}_remove += " obmc-host-startmin@.target"
+SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-poweron@.target"
+SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-poweroff@.target"
+SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-hard-poweroff@.target"
+SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-powerreset@.target"
diff --git a/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb b/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
index d69ea5197..2490a5cfe 100644
--- a/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
+++ b/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
@@ -45,5 +45,6 @@ RDEPENDS_${PN}-system = " \
bmcweb \
entity-manager \
intel-ipmi-oem \
+ dbus-sensors \
phosphor-webui \
"
diff --git a/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 6aa2460d0..6ad9a434c 100644
--- a/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -3,4 +3,5 @@ do_install_append(){
install -m 0644 -D ${S}/utils.hpp ${D}${includedir}/phosphor-ipmi-host
install -m 0644 -D ${S}/types.hpp ${D}${includedir}/phosphor-ipmi-host
install -m 0644 -D ${S}/sensorhandler.hpp ${D}${includedir}/phosphor-ipmi-host
+ install -m 0644 -D ${S}/selutility.hpp ${D}${includedir}/phosphor-ipmi-host
}
diff --git a/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
new file mode 100644
index 000000000..8ef3a5dfa
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for Intel"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-utils
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
diff --git a/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml
new file mode 100755
index 000000000..813ffbfd4
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml
@@ -0,0 +1,36 @@
+bmc_booted:
+
+power_on:
+
+status_ok:
+ status_green:
+ Action: 'On'
+ status_amber:
+ Action: 'Off'
+
+status_degraded:
+ status_green:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+ status_amber:
+ Action: 'Off'
+
+status_non_critical:
+ status_green:
+ Action: 'Off'
+ status_amber:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+status_critical:
+ status_green:
+ Action: 'Off'
+ status_amber:
+ Action: 'On'
+
+enclosure_identify:
+ identify:
+ Action: 'On'
+
OpenPOWER on IntegriCloud