summaryrefslogtreecommitdiffstats
path: root/meta-intel/meta-common/recipes-phosphor/leds
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel/meta-common/recipes-phosphor/leds')
-rw-r--r--meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb19
-rwxr-xr-xmeta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml36
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
new file mode 100644
index 000000000..8ef3a5dfa
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for Intel"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-utils
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
diff --git a/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml
new file mode 100755
index 000000000..813ffbfd4
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config/led.yaml
@@ -0,0 +1,36 @@
+bmc_booted:
+
+power_on:
+
+status_ok:
+ status_green:
+ Action: 'On'
+ status_amber:
+ Action: 'Off'
+
+status_degraded:
+ status_green:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+ status_amber:
+ Action: 'Off'
+
+status_non_critical:
+ status_green:
+ Action: 'Off'
+ status_amber:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+status_critical:
+ status_green:
+ Action: 'Off'
+ status_amber:
+ Action: 'On'
+
+enclosure_identify:
+ identify:
+ Action: 'On'
+
OpenPOWER on IntegriCloud