summaryrefslogtreecommitdiffstats
path: root/meta-ibm
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend1
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json60
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend b/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
new file mode 100644
index 000000000..72d991c7e
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..5ca21e3e2
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,60 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "PGOOD",
+ "power_up_outs": [
+ {"name": "POWER_PIN", "polarity": false}
+ ],
+ "reset_outs": [
+ {"name": "USB_RESET", "polarity": false}
+ ],
+ "pci_reset_outs": [
+ {"name": "PCIE_RESET", "polarity": false, "hold": false}
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "POWER_PIN",
+ "pin": "E1",
+ "direction": "out"
+ },
+ {
+ "name": "PGOOD",
+ "pin": "C7",
+ "direction": "in"
+ },
+ {
+ "name": "BMC_THROTTLE",
+ "pin": "J3",
+ "direction": "out"
+ },
+ {
+ "name": "IDBTN",
+ "pin": "Q7",
+ "direction": "out"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "E0",
+ "direction": "both"
+ },
+ {
+ "name": "PCIE_RESET",
+ "pin": "B5",
+ "direction": "out"
+ },
+ {
+ "name": "USB_RESET",
+ "pin": "B6",
+ "direction": "out"
+ },
+ {
+ "name": "CHECKSTOP",
+ "pin": "P5",
+ "direction": "falling"
+ }
+ ]
+}
OpenPOWER on IntegriCloud