summaryrefslogtreecommitdiffstats
path: root/import-layers/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb')
-rw-r--r--import-layers/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/import-layers/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/import-layers/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb
new file mode 100644
index 000000000..6d7c347c0
--- /dev/null
+++ b/import-layers/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Common X11 scripts and configuration files"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+SECTION = "x11"
+PR = "r47"
+
+inherit distro_features_check
+# rdepends on xdypinfo xmodmap xinit
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = "file://etc \
+ file://Xserver.in \
+ file://gplv2-license.patch"
+
+S = "${WORKDIR}"
+
+PACKAGECONFIG ??= "blank"
+# dpms and screen saver will be on only if 'blank' is in PACKAGECONFIG
+PACKAGECONFIG[blank] = ""
+
+do_install() {
+ cp -R ${S}/etc ${D}${sysconfdir}
+ sed -e 's/@BLANK_ARGS@/${@bb.utils.contains('PACKAGECONFIG', 'blank', '', '-s 0 -dpms', d)}/' \
+ ${S}/Xserver.in > ${D}${sysconfdir}/X11/Xserver
+
+ chmod -R 755 ${D}${sysconfdir}
+}
+
+RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"
+
OpenPOWER on IntegriCloud