summaryrefslogtreecommitdiffstats
path: root/import-layers/meta-virtualization/recipes-containers/riddler/riddler_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-virtualization/recipes-containers/riddler/riddler_git.bb')
-rw-r--r--import-layers/meta-virtualization/recipes-containers/riddler/riddler_git.bb50
1 files changed, 0 insertions, 50 deletions
diff --git a/import-layers/meta-virtualization/recipes-containers/riddler/riddler_git.bb b/import-layers/meta-virtualization/recipes-containers/riddler/riddler_git.bb
deleted file mode 100644
index 9f7fe6b4b..000000000
--- a/import-layers/meta-virtualization/recipes-containers/riddler/riddler_git.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-HOMEPAGE = "https://github.com/jfrazelle/riddler"
-SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec."
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1"
-
-SRC_URI = "git://github.com/jfrazelle/riddler;branch=master"
-SRCREV = "23befa0b232877b5b502b828e24161d801bd67f6"
-PV = "0.1.0+git${SRCPV}"
-GO_IMPORT = "import"
-
-S = "${WORKDIR}/git"
-
-inherit goarch
-inherit go
-
-# This disables seccomp and apparmor, which are on by default in the
-# go package.
-EXTRA_OEMAKE="BUILDTAGS=''"
-
-do_compile() {
- export GOARCH="${TARGET_GOARCH}"
- export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
- # Setup vendor directory so that it can be used in GOPATH.
- #
- # Go looks in a src directory under any directory in GOPATH but riddler
- # uses 'vendor' instead of 'vendor/src'. We can fix this with a symlink.
- #
- # We also need to link in the ipallocator directory as that is not under
- # a src directory.
- ln -sfn . "${S}/src/import/vendor/src"
- mkdir -p "${S}/src/import/vendor/src/github.com/jessfraz/riddler"
- ln -sfn "${S}/src/import/parse" "${S}/src/import/vendor/src/github.com/jessfraz/riddler/parse"
- export GOPATH="${S}/src/import/vendor"
-
- # Pass the needed cflags/ldflags so that cgo
- # can find the needed headers files and libraries
- export CGO_ENABLED="1"
- export CFLAGS=""
- export LDFLAGS=""
- export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
- export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
- cd ${S}/src/import
-
- oe_runmake static
-}
-
-do_install() {
- install -d ${D}/${sbindir}
- install ${S}/src/import/riddler ${D}/${sbindir}/riddler
-}
OpenPOWER on IntegriCloud