summaryrefslogtreecommitdiffstats
path: root/import-layers/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-raspberrypi/recipes-graphics/userland/userland_git.bb')
-rw-r--r--import-layers/meta-raspberrypi/recipes-graphics/userland/userland_git.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/import-layers/meta-raspberrypi/recipes-graphics/userland/userland_git.bb b/import-layers/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
index 6e73ca74b..a37249c82 100644
--- a/import-layers/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
+++ b/import-layers/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
@@ -16,7 +16,7 @@ COMPATIBLE_MACHINE = "raspberrypi"
SRCBRANCH = "master"
SRCFORK = "raspberrypi"
-SRCREV = "0147f98bdd4fdc822d25d8a70cf5adc5adb89096"
+SRCREV = "bb15afe33b313fe045d52277a78653d288e04f67"
SRC_URI = "\
git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
@@ -29,19 +29,23 @@ SRC_URI = "\
file://0007-initialize-front-back-wayland-buffers.patch \
file://0008-Remove-RPC_FLUSH.patch \
file://0009-fix-cmake-dependency-race.patch \
- file://0010-Fix-enum-conversion-warnings.patch \
- file://0011-Fix-for-framerate-with-nested-composition.patch \
- file://0012-build-shared-library-for-vchostif.patch \
- file://0013-implement-buffer-wrapping-interface-for-dispmanx.patch \
+ file://0010-Fix-for-framerate-with-nested-composition.patch \
+ file://0011-build-shared-library-for-vchostif.patch \
+ file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \
"
S = "${WORKDIR}/git"
inherit cmake pkgconfig
+ASNEEDED = ""
+
EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \
-DVMCS_INSTALL_PREFIX=${exec_prefix} \
"
+EXTRA_OECMAKE_append_aarch64 = " -DARM64=ON "
+
+
PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,,wayland-native wayland"
@@ -71,3 +75,5 @@ FILES_${PN}-doc += "${datadir}/install"
FILES_${PN}-dbg += "${libdir}/plugins/.debug"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+RDEPENDS_${PN} += "bash"
OpenPOWER on IntegriCloud