summaryrefslogtreecommitdiffstats
path: root/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-raspberrypi/recipes-devtools/pi-blaster')
-rw-r--r--import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch77
-rw-r--r--import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster.inc21
-rw-r--r--import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb3
3 files changed, 101 insertions, 0 deletions
diff --git a/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch b/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch
new file mode 100644
index 000000000..7ea9a3bde
--- /dev/null
+++ b/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch
@@ -0,0 +1,77 @@
+Remove dependencies on LSB functions
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Alex Lennon <ajlennon@dynamicdevices.co.uk>
+
+diff -ur git.org/pi-blaster.boot.sh git/pi-blaster.boot.sh
+--- git.org/pi-blaster.boot.sh 2014-05-20 14:49:44.378582168 +0100
++++ git/pi-blaster.boot.sh 2014-05-20 14:51:08.330582386 +0100
+@@ -28,12 +28,12 @@
+ [ -r /etc/default/$NAME ] && . /etc/default/$NAME
+
+ # Load the VERBOSE setting and other rcS variables
+-. /lib/init/vars.sh
++#. /lib/init/vars.sh
+
+ # Define LSB log_* functions.
+ # Depend on lsb-base (>= 3.2-14) to ensure that this file is present
+ # and status_of_proc is working.
+-. /lib/lsb/init-functions
++#. /lib/lsb/init-functions
+
+ #
+ # Function that starts the daemon/service
+@@ -77,48 +77,23 @@
+
+ case "$1" in
+ start)
+- [ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"
++ [ "$VERBOSE" != no ] && echo "Starting $DESC" "$NAME"
+ do_start
+- case "$?" in
+- 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
+- 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
+- esac
+ ;;
+ stop)
+- [ "$VERBOSE" != no ] && log_daemon_msg "Stopping $DESC" "$NAME"
++ [ "$VERBOSE" != no ] && echo "Stopping $DESC" "$NAME"
+ do_stop
+- case "$?" in
+- 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
+- 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
+- esac
+- ;;
+- status)
+- status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
+ ;;
+ restart|force-reload)
+ #
+ # If the "reload" option is implemented then remove the
+ # 'force-reload' alias
+ #
+- log_daemon_msg "Restarting $DESC" "$NAME"
+ do_stop
+- case "$?" in
+- 0|1)
+- do_start
+- case "$?" in
+- 0) log_end_msg 0 ;;
+- 1) log_end_msg 1 ;; # Old process is still running
+- *) log_end_msg 1 ;; # Failed to start
+- esac
+- ;;
+- *)
+- # Failed to stop
+- log_end_msg 1
+- ;;
+- esac
++ do_start
+ ;;
+ *)
+- echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
++ echo "Usage: $SCRIPTNAME {start|stop|restart}" >&2
+ exit 3
+ ;;
+ esac
diff --git a/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster.inc b/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster.inc
new file mode 100644
index 000000000..a3beccc02
--- /dev/null
+++ b/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi."
+HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
+SECTION = "devel/libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.md;beginline=157;endline=170;md5=f20832f31126609af5a7bf2340014540"
+
+SRC_URI = "git://github.com/sarfata/pi-blaster \
+ file://remove-initscript-lsb-dependency.patch \
+"
+
+S = "${WORKDIR}/git"
+
+inherit update-rc.d autotools
+
+INITSCRIPT_PACKAGES = "${PN}"
+INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
+INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
+
+COMPATIBLE_MACHINE = "raspberrypi"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb b/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb
new file mode 100644
index 000000000..263852b4f
--- /dev/null
+++ b/import-layers/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb
@@ -0,0 +1,3 @@
+require pi-blaster.inc
+
+SRCREV = "ec5e1b4c6191d8f9a538497dbbb86f9cf0de7016"
OpenPOWER on IntegriCloud