summaryrefslogtreecommitdiffstats
path: root/import-layers/meta-openembedded/meta-gnome/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-openembedded/meta-gnome/recipes-support')
-rw-r--r--import-layers/meta-openembedded/meta-gnome/recipes-support/florence/files/fix-no-atspi-compile.patch30
-rw-r--r--import-layers/meta-openembedded/meta-gnome/recipes-support/florence/florence_0.5.4.bb (renamed from import-layers/meta-openembedded/meta-gnome/recipes-support/florence/florence_0.5.1.bb)12
-rw-r--r--import-layers/meta-openembedded/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb2
-rw-r--r--import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker-0.14.2/giflib5-support.patch126
-rw-r--r--import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb10
5 files changed, 172 insertions, 8 deletions
diff --git a/import-layers/meta-openembedded/meta-gnome/recipes-support/florence/files/fix-no-atspi-compile.patch b/import-layers/meta-openembedded/meta-gnome/recipes-support/florence/files/fix-no-atspi-compile.patch
new file mode 100644
index 000000000..0bb5dee80
--- /dev/null
+++ b/import-layers/meta-openembedded/meta-gnome/recipes-support/florence/files/fix-no-atspi-compile.patch
@@ -0,0 +1,30 @@
+diff --git a/src/florence.c b/src/florence.c
+index b27c31b..feadefe 100644
+--- a/src/florence.c
++++ b/src/florence.c
+@@ -44,12 +44,6 @@
+ /* exit signal */
+ static int flo_exit=FALSE;
+
+-#ifdef ENABLE_AT_SPI2
+-void flo_check_show (struct florence *florence, AtspiAccessible *obj);
+-#else
+-void flo_check_show (struct florence *florence, Accessible *obj);
+-#endif
+-
+ /* Called on destroy event (systray quit or close window) */
+ void flo_destroy (void)
+ {
+@@ -61,6 +55,12 @@ void flo_destroy (void)
+ }
+
+ #ifdef AT_SPI
++#ifdef ENABLE_AT_SPI2
++void flo_check_show (struct florence *florence, AtspiAccessible *obj);
++#else
++void flo_check_show (struct florence *florence, Accessible *obj);
++#endif
++
+ /* Called to destroy the icon */
+ void flo_icon_destroy (GtkWidget *widget, gpointer user_data)
+ {
diff --git a/import-layers/meta-openembedded/meta-gnome/recipes-support/florence/florence_0.5.1.bb b/import-layers/meta-openembedded/meta-gnome/recipes-support/florence/florence_0.5.4.bb
index 71014f087..dfdb6bdb8 100644
--- a/import-layers/meta-openembedded/meta-gnome/recipes-support/florence/florence_0.5.1.bb
+++ b/import-layers/meta-openembedded/meta-gnome/recipes-support/florence/florence_0.5.4.bb
@@ -8,13 +8,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
PR = "r1"
-DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native gnome-doc-utils libnotify"
+DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native gnome-doc-utils libnotify gstreamer"
-SRC_URI = "${SOURCEFORGE_MIRROR}/florence/florence/${PV}/florence-${PV}.tar.bz2 \
- file://0001-Fix-glib-includes.patch"
-SRC_URI[md5sum] = "56d12e5b47c100d9df172aa5ddc0f609"
-SRC_URI[sha256sum] = "7b06ed84ef2b7b22d8d2cf0c7d013a05409bd82028240ac8719a68b192d5bc62"
+SRC_URI = "${SOURCEFORGE_MIRROR}/florence/florence/${PV}-gtk2/florence-${PV}.tar.bz2 \
+ file://fix-no-atspi-compile.patch"
+SRC_URI[md5sum] = "8d5c2367a28485bfcf577650b0badab7"
+SRC_URI[sha256sum] = "26d33aa20d5fbf34ceeded4c41cb922d2988b6082e33d9acc46dd7bfe56d31a1"
inherit gettext autotools gconf pkgconfig
-EXTRA_OECONF = "--disable-scrollkeeper --without-docs --without-at-spi --without-panelapplet"
+EXTRA_OECONF = "--disable-scrollkeeper --without-docs --without-at-spi --without-panelapplet --without-xrecord"
diff --git a/import-layers/meta-openembedded/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb b/import-layers/meta-openembedded/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
index 919aa7bca..ab20460f1 100644
--- a/import-layers/meta-openembedded/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
+++ b/import-layers/meta-openembedded/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
@@ -47,3 +47,5 @@ python populate_packages_prepend () {
do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
}
+# | ../../goffice-0.10.1/goffice/math/go-complex.c:75:3: error: format not a string literal, argument types not checked [-Werror=format-nonliteral]
+PNBLACKLIST[goffice] ?= "BROKEN: fails to build with gcc-6"
diff --git a/import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker-0.14.2/giflib5-support.patch b/import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker-0.14.2/giflib5-support.patch
new file mode 100644
index 000000000..fab3371f0
--- /dev/null
+++ b/import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker-0.14.2/giflib5-support.patch
@@ -0,0 +1,126 @@
+ src/tracker-extract/tracker-extract-gif.c | 36 +++++++++++++++++++++++++++++
+ 1 file changed, 36 insertions(+)
+--- a/src/tracker-extract/tracker-extract-gif.c
++++ a/src/tracker-extract/tracker-extract-gif.c
+@@ -75,6 +75,39 @@
+ return (GIF_OK);
+ }
+
++#if GIFLIB_MAJOR >= 5
++static inline void
++gif_error (const gchar *action, int err)
++{
++ const char *str = GifErrorString (err);
++ if (str != NULL) {
++ g_message ("%s, error: '%s'", action, str);
++ } else {
++ g_message ("%s, undefined error %d", action, err);
++ }
++}
++#else /* GIFLIB_MAJOR >= 5 */
++static inline void print_gif_error()
++{
++#if defined(GIFLIB_MAJOR) && defined(GIFLIB_MINOR) && ((GIFLIB_MAJOR == 4 && GIFLIB_MINOR >= 2) || GIFLIB_MAJOR > 4)
++ const char *str = GifErrorString ();
++ if (str != NULL) {
++ g_message ("GIF, error: '%s'", str);
++ } else {
++ g_message ("GIF, undefined error");
++ }
++#else
++ PrintGifError();
++#endif
++}
++#endif /* GIFLIB_MAJOR >= 5 */
++
++/* giflib 5.1 changed the API of DGifCloseFile to take two arguments */
++#if !defined(GIFLIB_MAJOR) || \
++ !(GIFLIB_MAJOR > 5 || (GIFLIB_MAJOR == 5 && GIFLIB_MINOR >= 1))
++#define DGifCloseFile(a, b) DGifCloseFile(a)
++#endif
++
+ static void
+ read_metadata (TrackerSparqlBuilder *preupdate,
+ TrackerSparqlBuilder *metadata,
+@@ -100,14 +133,22 @@
+ ExtBlock extBlock;
+
+ if (DGifGetRecordType(gifFile, &RecordType) == GIF_ERROR) {
+- PrintGifError();
++#if GIFLIB_MAJOR < 5
++ print_gif_error ();
++#else /* GIFLIB_MAJOR < 5 */
++ gif_error ("Could not read next GIF record type", gifFile->Error);
++#endif /* GIFLIB_MAJOR < 5 */
+ return;
+ }
+
+ switch (RecordType) {
+ case IMAGE_DESC_RECORD_TYPE:
+ if (DGifGetImageDesc(gifFile) == GIF_ERROR) {
+- PrintGifError();
++#if GIFLIB_MAJOR < 5
++ print_gif_error();
++#else /* GIFLIB_MAJOR < 5 */
++ gif_error ("Could not get GIF record information", gifFile->Error);
++#endif /* GIFLIB_MAJOR < 5 */
+ return;
+ }
+
+@@ -117,7 +158,11 @@
+ framedata = g_malloc (framewidth*frameheight);
+
+ if (DGifGetLine(gifFile, framedata, framewidth*frameheight)==GIF_ERROR) {
+- PrintGifError();
++#if GIFLIB_MAJOR < 5
++ print_gif_error();
++#else /* GIFLIB_MAJOR < 5 */
++ gif_error ("Could not load a block of GIF pixes", gifFile->Error);
++#endif /* GIFLIB_MAJOR < 5 */
+ return;
+ }
+
+@@ -593,6 +638,9 @@
+ gchar *filename, *uri;
+ GFile *file;
+ int fd;
++#if GIFLIB_MAJOR >= 5
++ int err;
++#endif
+
+ preupdate = tracker_extract_info_get_preupdate_builder (info);
+ metadata = tracker_extract_info_get_metadata_builder (info);
+@@ -617,8 +665,14 @@
+ return FALSE;
+ }
+
++#if GIFLIB_MAJOR < 5
+ if ((gifFile = DGifOpenFileHandle (fd)) == NULL) {
+- PrintGifError ();
++ print_gif_error ();
++#else /* GIFLIB_MAJOR < 5 */
++ if ((gifFile = DGifOpenFileHandle (fd, &err)) == NULL) {
++ gif_error ("Could not open GIF file with handle", err);
++#endif /* GIFLIB_MAJOR < 5 */
++ g_free (filename);
+ close (fd);
+ return FALSE;
+ }
+@@ -637,10 +691,15 @@
+ g_string_free (where, TRUE);
+
+ g_free (uri);
+-
++#if GIFLIB_MAJOR < 5
+ if (DGifCloseFile (gifFile) != GIF_OK) {
+- PrintGifError ();
++ print_gif_error ();
++ }
++#else /* GIFLIB_MAJOR < 5 */
++ if (DGifCloseFile (gifFile, NULL) != GIF_OK) {
++ gif_error ("Could not close GIF file", gifFile->Error);
+ }
++#endif /* GIFLIB_MAJOR < 5 */
+
+ return TRUE;
+ }
diff --git a/import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb b/import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb
index c52d95e97..7025280b8 100644
--- a/import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb
+++ b/import-layers/meta-openembedded/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb
@@ -1,9 +1,11 @@
DESCRIPTION = "Tracker is a tool designed to extract information and metadata about your personal data so that it can be searched easily and quickly."
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=ee31012bf90e7b8c108c69f197f3e3a4"
-DEPENDS = "file gstreamer dbus libexif gettext sqlite3 icu gst-plugins-base libgnome-keyring poppler tiff enca libgsf libunistring giflib taglib bzip2 upower gtk+3 libgee networkmanager"
+DEPENDS = "file gstreamer dbus libexif gettext sqlite3 icu gst-plugins-base libgnome-keyring poppler tiff enca libgsf libunistring giflib taglib bzip2 upower gtk+3 libgee networkmanager intltool-native"
RDEPENDS_${PN} += " gvfs gsettings-desktop-schemas"
+
+RDEPENDS_${PN}-nautilus-extension += "nautilus"
HOMEPAGE = "http://projects.gnome.org/tracker/"
PR = "r7"
@@ -13,7 +15,8 @@ inherit autotools pkgconfig gnomebase gettext gsettings systemd gobject-introspe
VER_DIR = "${@gnome_verdir("${PV}")}"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/tracker/${VER_DIR}/tracker-${PV}.tar.xz \
file://enable-sqlite-crosscompile.patch \
- file://fix-removable-media-detection.patch \
+ file://fix-removable-media-detection.patch \
+ file://giflib5-support.patch \
file://90tracker \
file://tracker-store.service \
file://tracker-miner-fs.service \
@@ -80,3 +83,6 @@ FILES_${PN}-nautilus-extension += "${libdir}/nautilus/extensions-2.0/*.so"
SRC_URI[md5sum] = "f3a871beeebf86fd752863ebd22af9ac"
SRC_URI[sha256sum] = "9b59330aa2e9e09feee587ded895e9247f71fc25f46b023d616d9969314bc7f1"
+
+# http://errors.yoctoproject.org/Errors/Details/81007/
+PNBLACKLIST[tracker] ?= "BROKEN: fails to build with new binutils-2.27"
OpenPOWER on IntegriCloud