summaryrefslogtreecommitdiffstats
path: root/meta-rcs
diff options
context:
space:
mode:
authorTimothy Pearson <tpearson@raptorengineering.com>2019-04-19 09:14:15 +0000
committerTimothy Pearson <tpearson@raptorengineering.com>2019-04-25 08:02:06 +0000
commitd34e2ad521dd7026cfdfa4bc946dbe77dca0089b (patch)
tree04f34b97182e71f73dcdb301c9450a394fa04eb0 /meta-rcs
parent49dfe571c691e1a6afe8957ff4bccbd7fcd20f66 (diff)
downloadtalos-openbmc-d34e2ad521dd7026cfdfa4bc946dbe77dca0089b.tar.gz
talos-openbmc-d34e2ad521dd7026cfdfa4bc946dbe77dca0089b.zip
Move RCS specific layers to correct location for latest OpenBMC
Diffstat (limited to 'meta-rcs')
-rw-r--r--meta-rcs/recipes-phosphor/chassis/obmc-hardbeep.bb9
-rw-r--r--meta-rcs/recipes-phosphor/chassis/obmc-softbeep.bb9
-rw-r--r--meta-rcs/recipes-phosphor/host/ast-vga-disable.bb33
-rwxr-xr-xmeta-rcs/recipes-phosphor/host/ast-vga-disable/ast-vga-disable-check13
-rw-r--r--meta-rcs/recipes-phosphor/host/ast-vga-disable/ast_vga_disable@.service19
-rw-r--r--meta-rcs/recipes-phosphor/system/obmc-ipl-status-led-monitor.bb23
-rw-r--r--meta-rcs/recipes-phosphor/system/obmc-ipl-status-led-monitor/org.openbmc.status.IPLLED.service14
-rw-r--r--meta-rcs/recipes-phosphor/system/obmc-ipl-status-observer.bb23
-rw-r--r--meta-rcs/recipes-phosphor/system/obmc-ipl-status-observer/org.openbmc.status.IPL.service15
9 files changed, 158 insertions, 0 deletions
diff --git a/meta-rcs/recipes-phosphor/chassis/obmc-hardbeep.bb b/meta-rcs/recipes-phosphor/chassis/obmc-hardbeep.bb
new file mode 100644
index 000000000..8066752e2
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/chassis/obmc-hardbeep.bb
@@ -0,0 +1,9 @@
+SUMMARY = "OpenBMC hardware PWM beep"
+DESCRIPTION = "A sample implementation for hardware beep on a PWM."
+PR = "r1"
+
+inherit skeleton-gdbus
+inherit pkgconfig
+
+LICENSE = "GPLv3"
+SKELETON_DIR = "hardbeep"
diff --git a/meta-rcs/recipes-phosphor/chassis/obmc-softbeep.bb b/meta-rcs/recipes-phosphor/chassis/obmc-softbeep.bb
new file mode 100644
index 000000000..034d5c4c4
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/chassis/obmc-softbeep.bb
@@ -0,0 +1,9 @@
+SUMMARY = "OpenBMC software beep"
+DESCRIPTION = "A sample implementation for software beep on a GPIO."
+PR = "r1"
+
+inherit skeleton-gdbus
+inherit pkgconfig
+
+LICENSE = "GPLv3"
+SKELETON_DIR = "softbeep"
diff --git a/meta-rcs/recipes-phosphor/host/ast-vga-disable.bb b/meta-rcs/recipes-phosphor/host/ast-vga-disable.bb
new file mode 100644
index 000000000..fc5b567be
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/host/ast-vga-disable.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Talos II VGA Disable"
+DESCRIPTION = "Talos II power on VGA disable controller"
+PR = "r0"
+
+LICENSE = "LGPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
+ file://COPYING.LESSER;md5=3000208d539ec061b899bce1d9ce9404 \
+ "
+
+inherit obmc-phosphor-systemd
+
+PROVIDES += 'virtual/talos-ast-vga-disable'
+RPROVIDES_${PN} += 'virtual-talos-ast-vga-disable'
+
+RDEPENDS_${PN} += "bash"
+
+S = "${WORKDIR}"
+SRC_URI += "file://ast-vga-disable-check"
+SRC_URI += "file://COPYING"
+SRC_URI += "file://COPYING.LESSER"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/ast-vga-disable-check ${D}${bindir}/ast-vga-disable-check
+}
+
+TMPL = "ast_vga_disable@.service"
+INSTFMT = "ast_vga_disable@{0}.service"
+TGTFMT = "obmc-chassis-poweron@{0}.target"
+FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-rcs/recipes-phosphor/host/ast-vga-disable/ast-vga-disable-check b/meta-rcs/recipes-phosphor/host/ast-vga-disable/ast-vga-disable-check
new file mode 100755
index 000000000..31ed3dff7
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/host/ast-vga-disable/ast-vga-disable-check
@@ -0,0 +1,13 @@
+#!/bin/bash
+#
+# Copyright © 2018 Raptor Engineering, LLC
+
+FPGA_STATUS=$(i2cget -y 12 0x31 0x7)
+AST_VGA_DISABLE=$(( FPGA_STATUS & 0x40 ))
+if [[ $AST_VGA_DISABLE == 64 ]]; then
+ # On-board VGA disabled
+ devmem 0x1e6e207c 32 0x00008000
+else
+ # On-board VGA enabled
+ devmem 0x1e6e2070 32 0x00008000
+fi
diff --git a/meta-rcs/recipes-phosphor/host/ast-vga-disable/ast_vga_disable@.service b/meta-rcs/recipes-phosphor/host/ast-vga-disable/ast_vga_disable@.service
new file mode 100644
index 000000000..2e52c9e3c
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/host/ast-vga-disable/ast_vga_disable@.service
@@ -0,0 +1,19 @@
+[Unit]
+Description=Apply ASpeed VGA disable setting on host%i
+Wants=obmc-host-start-pre@%i.target
+Before=obmc-host-start-pre@%i.target
+Wants=obmc-power-on@%i.target
+After=obmc-power-on@%i.target
+Wants=fsi-scan@%i.service
+After=fsi-scan@%i.service
+Conflicts=obmc-chassis-poweroff@%i.target
+ConditionPathExists=!/run/openbmc/chassis@%i-on
+
+[Service]
+ExecStart=/usr/bin/env /usr/bin/ast-vga-disable-check
+SyslogIdentifier=ast-vga-disable-check
+Type=oneshot
+RemainAfterExit=yes
+
+[Install]
+WantedBy=obmc-chassis-poweron@%i.target
diff --git a/meta-rcs/recipes-phosphor/system/obmc-ipl-status-led-monitor.bb b/meta-rcs/recipes-phosphor/system/obmc-ipl-status-led-monitor.bb
new file mode 100644
index 000000000..cf4520368
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/system/obmc-ipl-status-led-monitor.bb
@@ -0,0 +1,23 @@
+SUMMARY = "OpenBMC IPL status LED monitor"
+DESCRIPTION = "OpenBMC IPL status LED monitor."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-subprocess \
+ python-pygobject \
+ pyphosphor \
+ pyphosphor-dbus \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ obmc-ipl-status-observer \
+ "
+
+SKELETON_DIR = "pyiplledmonitor"
+
+DBUS_SERVICE_${PN} += "org.openbmc.status.IPLLED.service"
diff --git a/meta-rcs/recipes-phosphor/system/obmc-ipl-status-led-monitor/org.openbmc.status.IPLLED.service b/meta-rcs/recipes-phosphor/system/obmc-ipl-status-led-monitor/org.openbmc.status.IPLLED.service
new file mode 100644
index 000000000..c1daa0469
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/system/obmc-ipl-status-led-monitor/org.openbmc.status.IPLLED.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Phoshpor IPL Status LED Monitor
+Wants=org.openbmc.status.IPL.service
+After=org.openbmc.status.IPL.service
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env ipl_status_led_monitor.py
+SyslogIdentifier=ipl_status_led_monitor.py
+Type=simple
+Environment="PYTHONUNBUFFERED=1"
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-rcs/recipes-phosphor/system/obmc-ipl-status-observer.bb b/meta-rcs/recipes-phosphor/system/obmc-ipl-status-observer.bb
new file mode 100644
index 000000000..95d358e3d
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/system/obmc-ipl-status-observer.bb
@@ -0,0 +1,23 @@
+SUMMARY = "OpenBMC IPL status observer"
+DESCRIPTION = "OpenBMC IPL status observer."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-subprocess \
+ python-pygobject \
+ pyphosphor \
+ pyphosphor-dbus \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ pdbg \
+ "
+
+SKELETON_DIR = "pyiplobserver"
+
+DBUS_SERVICE_${PN} += "org.openbmc.status.IPL.service"
diff --git a/meta-rcs/recipes-phosphor/system/obmc-ipl-status-observer/org.openbmc.status.IPL.service b/meta-rcs/recipes-phosphor/system/obmc-ipl-status-observer/org.openbmc.status.IPL.service
new file mode 100644
index 000000000..a92b2f146
--- /dev/null
+++ b/meta-rcs/recipes-phosphor/system/obmc-ipl-status-observer/org.openbmc.status.IPL.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Phoshpor IPL Status Observer
+Wants=xyz.openbmc_project.State.Host.service
+After=xyz.openbmc_project.State.Host.service
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env ipl_status_observer.py
+SyslogIdentifier=ipl_status_observer.py
+Type=dbus
+BusName={BUSNAME}
+Environment="PYTHONUNBUFFERED=1"
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
OpenPOWER on IntegriCloud