summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-05-07 15:42:31 +0200
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 17:02:24 -0400
commitf27bdd5a35e1af32ca3e200810222230d5fbee44 (patch)
treef2a27a208c72553cb2d0112bb3104c148aa9ce60 /meta-raspberrypi
parentb19b94b9dcd289f0fae54a4fde03d3df401c96ab (diff)
downloadtalos-openbmc-f27bdd5a35e1af32ca3e200810222230d5fbee44.tar.gz
talos-openbmc-f27bdd5a35e1af32ca3e200810222230d5fbee44.zip
meta-raspberrypi: sumo refresh 05f21adb99..ade31d6d01
Update meta-raspberrypi to sumo HEAD. Andrei Gherzan (4): raspberrypi3-64.conf: Include cm3 dtb linux-raspberrypi: Update to v4.14.58 rpi-base.inc: Split overlays and dtbs from KERNEL_DEVICETREE raspberrypi3-64.conf: Define only the dtb files that are available for arch64 Anton Gerasimov (3): rpi-base.inc: install at86rf233 overlay rpi-config: load at86rf233 overlay docs: document support for 802.15.4 hat Eduardo Abinader (1): config_git.bb: Remove extra space Hugo Hromic (5): formfactor: use `rpi` instead of `raspberrypi` to apply to all rpi machines meta-raspberrypi: use `_%` suffix instead of specific versions for bbappends pi-bluetooth: use `_git` suffix in recipe filename meta-raspberrypi: use generic licenses in ${COMMON_LICENSE_DIR} from Poky wiringpi: use lower-case in recipe directory name Khem Raj (2): firmware: Update to 20180619 release linux-raspberrypi: Update to 4.14.52+ Martin Jansa (3): sdcard_image-rpi.bbclass: copy the DTB files with canonical name sdcard_image-rpi: add dependency on rpi-u-boot-scr sdcard_image-rpi.bbclass: use 4 spaces for indentation instead of mix of tabs and spaces Steve Pavao (1): rpi-hwup-image.bb: Modified the warning message in do_image_prepend() Change-Id: If6ee02907ad0f08816eb4d5dad9c92f0d93e252c Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-raspberrypi')
-rw-r--r--meta-raspberrypi/classes/sdcard_image-rpi.bbclass219
-rw-r--r--meta-raspberrypi/conf/machine/include/rpi-base.inc28
-rw-r--r--meta-raspberrypi/conf/machine/raspberrypi3-64.conf22
-rw-r--r--meta-raspberrypi/docs/extra-build-config.md8
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb10
-rw-r--r--meta-raspberrypi/recipes-bsp/common/firmware.inc8
-rw-r--r--meta-raspberrypi/recipes-bsp/formfactor/formfactor/rpi/machconfig (renamed from meta-raspberrypi/recipes-bsp/formfactor/formfactor/raspberrypi/machconfig)0
-rw-r--r--meta-raspberrypi/recipes-bsp/formfactor/formfactor_%.bbappend (renamed from meta-raspberrypi/recipes-bsp/formfactor/formfactor_0.0.bbappend)0
-rw-r--r--meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb2
-rw-r--r--meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb (renamed from meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth.bb)0
-rw-r--r--meta-raspberrypi/recipes-core/images/rpi-hwup-image.bb2
-rw-r--r--meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb2
-rw-r--r--meta-raspberrypi/recipes-core/psplash/psplash_%.bbappend (renamed from meta-raspberrypi/recipes-core/psplash/psplash_git.bbappend)0
-rw-r--r--meta-raspberrypi/recipes-core/udev/udev-rules-rpi.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/wiringpi/files/0001-Add-initial-cross-compile-support.patch (renamed from meta-raspberrypi/recipes-devtools/wiringPi/files/0001-Add-initial-cross-compile-support.patch)0
-rw-r--r--meta-raspberrypi/recipes-devtools/wiringpi/wiringpi_git.bb (renamed from meta-raspberrypi/recipes-devtools/wiringPi/wiringpi_git.bb)0
-rw-r--r--meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend (renamed from meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend)0
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb4
-rw-r--r--meta-raspberrypi/recipes-multimedia/x264/x264_%.bbappend (renamed from meta-raspberrypi/recipes-multimedia/x264/x264_git.bbappend)0
19 files changed, 152 insertions, 155 deletions
diff --git a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
index f03595c2c..e7c34c63f 100644
--- a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
+++ b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
@@ -50,13 +50,14 @@ SDIMG_ROOTFS_TYPE ?= "ext3"
SDIMG_ROOTFS = "${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.${SDIMG_ROOTFS_TYPE}"
do_image_rpi_sdimg[depends] = " \
- parted-native:do_populate_sysroot \
- mtools-native:do_populate_sysroot \
- dosfstools-native:do_populate_sysroot \
- virtual/kernel:do_deploy \
- ${IMAGE_BOOTLOADER}:do_deploy \
- ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \
- "
+ parted-native:do_populate_sysroot \
+ mtools-native:do_populate_sysroot \
+ dosfstools-native:do_populate_sysroot \
+ virtual/kernel:do_deploy \
+ ${IMAGE_BOOTLOADER}:do_deploy \
+ ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \
+ ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'rpi-u-boot-scr:do_deploy', '',d)} \
+"
do_image_rpi_sdimg[recrdeps] = "do_build"
@@ -79,6 +80,7 @@ SDIMG_LINK_VFAT = "${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.vfat"
def split_overlays(d, out, ver=None):
dts = d.getVar("KERNEL_DEVICETREE")
+ # Device Tree Overlays are assumed to be suffixed by '-overlay.dtb' (4.1.x) or by '.dtbo' (4.4.9+) string and will be put in a dedicated folder
if out:
overlays = oe.utils.str_filter_out('\S+\-overlay\.dtb$', dts, d)
overlays = oe.utils.str_filter_out('\S+\.dtbo$', overlays, d)
@@ -90,114 +92,107 @@ def split_overlays(d, out, ver=None):
IMAGE_CMD_rpi-sdimg () {
- # Align partitions
- BOOT_SPACE_ALIGNED=$(expr ${BOOT_SPACE} + ${IMAGE_ROOTFS_ALIGNMENT} - 1)
- BOOT_SPACE_ALIGNED=$(expr ${BOOT_SPACE_ALIGNED} - ${BOOT_SPACE_ALIGNED} % ${IMAGE_ROOTFS_ALIGNMENT})
- SDIMG_SIZE=$(expr ${IMAGE_ROOTFS_ALIGNMENT} + ${BOOT_SPACE_ALIGNED} + $ROOTFS_SIZE)
-
- echo "Creating filesystem with Boot partition ${BOOT_SPACE_ALIGNED} KiB and RootFS $ROOTFS_SIZE KiB"
-
- # Check if we are building with device tree support
- DTS="${KERNEL_DEVICETREE}"
-
- # Initialize sdcard image file
- dd if=/dev/zero of=${SDIMG} bs=1024 count=0 seek=${SDIMG_SIZE}
-
- # Create partition table
- parted -s ${SDIMG} mklabel msdos
- # Create boot partition and mark it as bootable
- parted -s ${SDIMG} unit KiB mkpart primary fat32 ${IMAGE_ROOTFS_ALIGNMENT} $(expr ${BOOT_SPACE_ALIGNED} \+ ${IMAGE_ROOTFS_ALIGNMENT})
- parted -s ${SDIMG} set 1 boot on
- # Create rootfs partition to the end of disk
- parted -s ${SDIMG} -- unit KiB mkpart primary ext2 $(expr ${BOOT_SPACE_ALIGNED} \+ ${IMAGE_ROOTFS_ALIGNMENT}) -1s
- parted ${SDIMG} print
-
- # Create a vfat image with boot files
- BOOT_BLOCKS=$(LC_ALL=C parted -s ${SDIMG} unit b print | awk '/ 1 / { print substr($4, 1, length($4 -1)) / 512 /2 }')
- rm -f ${WORKDIR}/boot.img
- mkfs.vfat -n "${BOOTDD_VOLUME_ID}" -S 512 -C ${WORKDIR}/boot.img $BOOT_BLOCKS
- mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/bcm2835-bootfiles/* ::/
- if test -n "${DTS}"; then
- # Device Tree Overlays are assumed to be suffixed by '-overlay.dtb' (4.1.x) or by '.dtbo' (4.4.9+) string and will be put in a dedicated folder
- DT_OVERLAYS="${@split_overlays(d, 0)}"
- DT_ROOT="${@split_overlays(d, 1)}"
-
- # Copy board device trees to root folder
- for DTB in $DT_ROOT; do
- DTB_BASE_NAME=`basename ${DTB} .dtb`
-
- mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${DTB_BASE_NAME}.dtb ::${DTB_BASE_NAME}.dtb
- done
-
- # Copy device tree overlays to dedicated folder
- mmd -i ${WORKDIR}/boot.img overlays
- for DTB in $DT_OVERLAYS; do
- DTB_EXT=${DTB##*.}
- DTB_BASE_NAME=`basename ${DTB} ."${DTB_EXT}"`
-
- mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${DTB_BASE_NAME}.${DTB_EXT} ::overlays/${DTB_BASE_NAME}.${DTB_EXT}
- done
- fi
- if [ "${RPI_USE_U_BOOT}" = "1" ]; then
- mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/u-boot.bin ::${SDIMG_KERNELIMAGE}
- mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}${KERNEL_INITRAMFS}-${MACHINE}.bin ::${KERNEL_IMAGETYPE}
- mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/boot.scr ::boot.scr
- else
- mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}${KERNEL_INITRAMFS}-${MACHINE}.bin ::${SDIMG_KERNELIMAGE}
- fi
-
- if [ -n ${FATPAYLOAD} ] ; then
- echo "Copying payload into VFAT"
- for entry in ${FATPAYLOAD} ; do
- # add the || true to stop aborting on vfat issues like not supporting .~lock files
- mcopy -i ${WORKDIR}/boot.img -s -v ${IMAGE_ROOTFS}$entry :: || true
- done
- fi
-
- # Add stamp file
- echo "${IMAGE_NAME}" > ${WORKDIR}/image-version-info
- mcopy -i ${WORKDIR}/boot.img -v ${WORKDIR}/image-version-info ::
-
- # Deploy vfat partition (for u-boot case only)
- if [ "${RPI_USE_U_BOOT}" = "1" ]; then
- cp ${WORKDIR}/boot.img ${IMGDEPLOYDIR}/${SDIMG_VFAT}
- ln -sf ${SDIMG_VFAT} ${SDIMG_LINK_VFAT}
- fi
-
- # Burn Partitions
- dd if=${WORKDIR}/boot.img of=${SDIMG} conv=notrunc seek=1 bs=$(expr ${IMAGE_ROOTFS_ALIGNMENT} \* 1024)
- # If SDIMG_ROOTFS_TYPE is a .xz file use xzcat
- if echo "${SDIMG_ROOTFS_TYPE}" | egrep -q "*\.xz"
- then
- xzcat ${SDIMG_ROOTFS} | dd of=${SDIMG} conv=notrunc seek=1 bs=$(expr 1024 \* ${BOOT_SPACE_ALIGNED} + ${IMAGE_ROOTFS_ALIGNMENT} \* 1024)
- else
- dd if=${SDIMG_ROOTFS} of=${SDIMG} conv=notrunc seek=1 bs=$(expr 1024 \* ${BOOT_SPACE_ALIGNED} + ${IMAGE_ROOTFS_ALIGNMENT} \* 1024)
- fi
-
- # Optionally apply compression
- case "${SDIMG_COMPRESSION}" in
- "gzip")
- gzip -k9 "${SDIMG}"
- ;;
- "bzip2")
- bzip2 -k9 "${SDIMG}"
- ;;
- "xz")
- xz -k "${SDIMG}"
- ;;
- esac
+ # Align partitions
+ BOOT_SPACE_ALIGNED=$(expr ${BOOT_SPACE} + ${IMAGE_ROOTFS_ALIGNMENT} - 1)
+ BOOT_SPACE_ALIGNED=$(expr ${BOOT_SPACE_ALIGNED} - ${BOOT_SPACE_ALIGNED} % ${IMAGE_ROOTFS_ALIGNMENT})
+ SDIMG_SIZE=$(expr ${IMAGE_ROOTFS_ALIGNMENT} + ${BOOT_SPACE_ALIGNED} + $ROOTFS_SIZE)
+
+ echo "Creating filesystem with Boot partition ${BOOT_SPACE_ALIGNED} KiB and RootFS $ROOTFS_SIZE KiB"
+
+ # Check if we are building with device tree support
+ DTS="${KERNEL_DEVICETREE}"
+
+ # Initialize sdcard image file
+ dd if=/dev/zero of=${SDIMG} bs=1024 count=0 seek=${SDIMG_SIZE}
+
+ # Create partition table
+ parted -s ${SDIMG} mklabel msdos
+ # Create boot partition and mark it as bootable
+ parted -s ${SDIMG} unit KiB mkpart primary fat32 ${IMAGE_ROOTFS_ALIGNMENT} $(expr ${BOOT_SPACE_ALIGNED} \+ ${IMAGE_ROOTFS_ALIGNMENT})
+ parted -s ${SDIMG} set 1 boot on
+ # Create rootfs partition to the end of disk
+ parted -s ${SDIMG} -- unit KiB mkpart primary ext2 $(expr ${BOOT_SPACE_ALIGNED} \+ ${IMAGE_ROOTFS_ALIGNMENT}) -1s
+ parted ${SDIMG} print
+
+ # Create a vfat image with boot files
+ BOOT_BLOCKS=$(LC_ALL=C parted -s ${SDIMG} unit b print | awk '/ 1 / { print substr($4, 1, length($4 -1)) / 512 /2 }')
+ rm -f ${WORKDIR}/boot.img
+ mkfs.vfat -n "${BOOTDD_VOLUME_ID}" -S 512 -C ${WORKDIR}/boot.img $BOOT_BLOCKS
+ mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/bcm2835-bootfiles/* ::/
+ if test -n "${DTS}"; then
+ # Copy board device trees to root folder
+ for dtbf in ${@split_overlays(d, True)}; do
+ dtb=`basename $dtbf`
+ mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/$dtb ::$dtb
+ done
+
+ # Copy device tree overlays to dedicated folder
+ mmd -i ${WORKDIR}/boot.img overlays
+ for dtbf in ${@split_overlays(d, False)}; do
+ dtb=`basename $dtbf`
+ mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/$dtb ::overlays/$dtb
+ done
+ fi
+ if [ "${RPI_USE_U_BOOT}" = "1" ]; then
+ mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/u-boot.bin ::${SDIMG_KERNELIMAGE}
+ mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}${KERNEL_INITRAMFS}-${MACHINE}.bin ::${KERNEL_IMAGETYPE}
+ mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/boot.scr ::boot.scr
+ else
+ mcopy -i ${WORKDIR}/boot.img -s ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}${KERNEL_INITRAMFS}-${MACHINE}.bin ::${SDIMG_KERNELIMAGE}
+ fi
+
+ if [ -n ${FATPAYLOAD} ] ; then
+ echo "Copying payload into VFAT"
+ for entry in ${FATPAYLOAD} ; do
+ # add the || true to stop aborting on vfat issues like not supporting .~lock files
+ mcopy -i ${WORKDIR}/boot.img -s -v ${IMAGE_ROOTFS}$entry :: || true
+ done
+ fi
+
+ # Add stamp file
+ echo "${IMAGE_NAME}" > ${WORKDIR}/image-version-info
+ mcopy -i ${WORKDIR}/boot.img -v ${WORKDIR}/image-version-info ::
+
+ # Deploy vfat partition (for u-boot case only)
+ if [ "${RPI_USE_U_BOOT}" = "1" ]; then
+ cp ${WORKDIR}/boot.img ${IMGDEPLOYDIR}/${SDIMG_VFAT}
+ ln -sf ${SDIMG_VFAT} ${SDIMG_LINK_VFAT}
+ fi
+
+ # Burn Partitions
+ dd if=${WORKDIR}/boot.img of=${SDIMG} conv=notrunc seek=1 bs=$(expr ${IMAGE_ROOTFS_ALIGNMENT} \* 1024)
+ # If SDIMG_ROOTFS_TYPE is a .xz file use xzcat
+ if echo "${SDIMG_ROOTFS_TYPE}" | egrep -q "*\.xz"
+ then
+ xzcat ${SDIMG_ROOTFS} | dd of=${SDIMG} conv=notrunc seek=1 bs=$(expr 1024 \* ${BOOT_SPACE_ALIGNED} + ${IMAGE_ROOTFS_ALIGNMENT} \* 1024)
+ else
+ dd if=${SDIMG_ROOTFS} of=${SDIMG} conv=notrunc seek=1 bs=$(expr 1024 \* ${BOOT_SPACE_ALIGNED} + ${IMAGE_ROOTFS_ALIGNMENT} \* 1024)
+ fi
+
+ # Optionally apply compression
+ case "${SDIMG_COMPRESSION}" in
+ "gzip")
+ gzip -k9 "${SDIMG}"
+ ;;
+ "bzip2")
+ bzip2 -k9 "${SDIMG}"
+ ;;
+ "xz")
+ xz -k "${SDIMG}"
+ ;;
+ esac
}
ROOTFS_POSTPROCESS_COMMAND += " rpi_generate_sysctl_config ; "
rpi_generate_sysctl_config() {
- # systemd sysctl config
- test -d ${IMAGE_ROOTFS}${sysconfdir}/sysctl.d && \
- echo "vm.min_free_kbytes = 8192" > ${IMAGE_ROOTFS}${sysconfdir}/sysctl.d/rpi-vm.conf
-
- # sysv sysctl config
- IMAGE_SYSCTL_CONF="${IMAGE_ROOTFS}${sysconfdir}/sysctl.conf"
- test -e ${IMAGE_ROOTFS}${sysconfdir}/sysctl.conf && \
- sed -e "/vm.min_free_kbytes/d" -i ${IMAGE_SYSCTL_CONF}
- echo "" >> ${IMAGE_SYSCTL_CONF} && echo "vm.min_free_kbytes = 8192" >> ${IMAGE_SYSCTL_CONF}
+ # systemd sysctl config
+ test -d ${IMAGE_ROOTFS}${sysconfdir}/sysctl.d && \
+ echo "vm.min_free_kbytes = 8192" > ${IMAGE_ROOTFS}${sysconfdir}/sysctl.d/rpi-vm.conf
+
+ # sysv sysctl config
+ IMAGE_SYSCTL_CONF="${IMAGE_ROOTFS}${sysconfdir}/sysctl.conf"
+ test -e ${IMAGE_ROOTFS}${sysconfdir}/sysctl.conf && \
+ sed -e "/vm.min_free_kbytes/d" -i ${IMAGE_SYSCTL_CONF}
+ echo "" >> ${IMAGE_SYSCTL_CONF} && echo "vm.min_free_kbytes = 8192" >> ${IMAGE_SYSCTL_CONF}
}
diff --git a/meta-raspberrypi/conf/machine/include/rpi-base.inc b/meta-raspberrypi/conf/machine/include/rpi-base.inc
index d76495a68..2af15886b 100644
--- a/meta-raspberrypi/conf/machine/include/rpi-base.inc
+++ b/meta-raspberrypi/conf/machine/include/rpi-base.inc
@@ -14,16 +14,7 @@ XSERVER = " \
${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "xf86-video-modesetting", "xf86-video-fbdev", d)} \
"
-KERNEL_DEVICETREE ?= " \
- bcm2708-rpi-0-w.dtb \
- bcm2708-rpi-b.dtb \
- bcm2708-rpi-b-plus.dtb \
- bcm2709-rpi-2-b.dtb \
- bcm2710-rpi-3-b.dtb \
- bcm2710-rpi-3-b-plus.dtb \
- bcm2708-rpi-cm.dtb \
- bcm2710-rpi-cm3.dtb \
- \
+RPI_KERNEL_DEVICETREE_OVERLAYS ?= " \
overlays/dwc2.dtbo \
overlays/hifiberry-amp.dtbo \
overlays/hifiberry-dac.dtbo \
@@ -43,6 +34,23 @@ KERNEL_DEVICETREE ?= " \
overlays/pi3-disable-bt.dtbo \
overlays/pi3-miniuart-bt.dtbo \
overlays/vc4-kms-v3d.dtbo \
+ overlays/at86rf233.dtbo \
+ "
+
+RPI_KERNEL_DEVICETREE ?= " \
+ bcm2708-rpi-0-w.dtb \
+ bcm2708-rpi-b.dtb \
+ bcm2708-rpi-b-plus.dtb \
+ bcm2709-rpi-2-b.dtb \
+ bcm2710-rpi-3-b.dtb \
+ bcm2710-rpi-3-b-plus.dtb \
+ bcm2708-rpi-cm.dtb \
+ bcm2710-rpi-cm3.dtb \
+ "
+
+KERNEL_DEVICETREE ?= " \
+ ${RPI_KERNEL_DEVICETREE} \
+ ${RPI_KERNEL_DEVICETREE_OVERLAYS} \
"
# By default:
diff --git a/meta-raspberrypi/conf/machine/raspberrypi3-64.conf b/meta-raspberrypi/conf/machine/raspberrypi3-64.conf
index 5163320da..fb21b122c 100644
--- a/meta-raspberrypi/conf/machine/raspberrypi3-64.conf
+++ b/meta-raspberrypi/conf/machine/raspberrypi3-64.conf
@@ -14,30 +14,10 @@ MACHINE_EXTRA_RRECOMMENDS += "\
require conf/machine/include/arm/arch-armv8.inc
include conf/machine/include/rpi-base.inc
-KERNEL_DEVICETREE = " \
+RPI_KERNEL_DEVICETREE = " \
broadcom/bcm2710-rpi-3-b.dtb \
broadcom/bcm2710-rpi-3-b-plus.dtb \
broadcom/bcm2837-rpi-3-b.dtb \
- \
- overlays/hifiberry-amp.dtbo \
- overlays/hifiberry-dac.dtbo \
- overlays/hifiberry-dacplus.dtbo \
- overlays/hifiberry-digi.dtbo \
- overlays/i2c-rtc.dtbo \
- overlays/iqaudio-dac.dtbo \
- overlays/iqaudio-dacplus.dtbo \
- overlays/lirc-rpi.dtbo \
- overlays/pitft22.dtbo \
- overlays/pitft28-resistive.dtbo \
- overlays/pitft35-resistive.dtbo \
- overlays/pps-gpio.dtbo \
- overlays/rpi-ft5406.dtbo \
- overlays/w1-gpio.dtbo \
- overlays/w1-gpio-pullup.dtbo \
- overlays/pi3-disable-bt.dtbo \
- overlays/pi3-miniuart-bt.dtbo \
- overlays/vc4-kms-v3d.dtbo \
- overlays/vc4-fkms-v3d.dtbo \
"
SERIAL_CONSOLE ?= "115200 ttyS0"
diff --git a/meta-raspberrypi/docs/extra-build-config.md b/meta-raspberrypi/docs/extra-build-config.md
index 806c23803..04314aa3d 100644
--- a/meta-raspberrypi/docs/extra-build-config.md
+++ b/meta-raspberrypi/docs/extra-build-config.md
@@ -237,6 +237,14 @@ local.conf:
ENABLE_DWC2_PERIPHERAL = "1"
+## Enable Openlabs 802.15.4 radio module
+
+When using device tree kernels, set this variable to enable the 802.15.4 hat:
+
+ ENABLE_AT86RF = "1"
+
+See: <https://openlabs.co/OSHW/Raspberry-Pi-802.15.4-radio>
+
## Manual additions to config.txt
The `RPI_EXTRA_CONFIG` variable can be used to manually add additional lines to
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index e0b2b58bc..a85c91630 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \
the ARM core is initialised. It can be used to set various \
system configuration parameters."
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
COMPATIBLE_MACHINE = "^rpi$"
@@ -177,7 +177,13 @@ do_deploy() {
echo "# Enable USB peripheral mode" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=dwc2,dr_mode=peripheral" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
-
+
+ # AT86RF23X support
+ if [ "${ENABLE_AT86RF}" = "1" ]; then
+ echo "# Enable AT86RF23X" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
# Append extra config if the user has provided any
echo "${RPI_EXTRA_CONFIG}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
}
diff --git a/meta-raspberrypi/recipes-bsp/common/firmware.inc b/meta-raspberrypi/recipes-bsp/common/firmware.inc
index d564a49ab..26cafb746 100644
--- a/meta-raspberrypi/recipes-bsp/common/firmware.inc
+++ b/meta-raspberrypi/recipes-bsp/common/firmware.inc
@@ -1,10 +1,10 @@
-RPIFW_DATE ?= "20180417"
-SRCREV ?= "5db8e4e1c63178e200d6fbea23ed4a9bf4656658"
+RPIFW_DATE ?= "20180619"
+SRCREV ?= "748fb17992426bb29d99224b93cb962fefbdc833"
RPIFW_SRC_URI ?= "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz"
RPIFW_S ?= "${WORKDIR}/firmware-${SRCREV}"
SRC_URI = "${RPIFW_SRC_URI}"
-SRC_URI[md5sum] = "6bce52f22a7a005a9bcdb9912b132590"
-SRC_URI[sha256sum] = "84568c4e7f5b0deee4cd76e7c0b48315885f983d6131d8148ef8af8438328a36"
+SRC_URI[md5sum] = "02edb854e9b72499225f3f93d322fe12"
+SRC_URI[sha256sum] = "07b2dc9d0779e15666e3ab596387e18cefc265d863c4bf6f8a0572b58a4fb793"
PV = "${RPIFW_DATE}"
diff --git a/meta-raspberrypi/recipes-bsp/formfactor/formfactor/raspberrypi/machconfig b/meta-raspberrypi/recipes-bsp/formfactor/formfactor/rpi/machconfig
index bef4ce3c9..bef4ce3c9 100644
--- a/meta-raspberrypi/recipes-bsp/formfactor/formfactor/raspberrypi/machconfig
+++ b/meta-raspberrypi/recipes-bsp/formfactor/formfactor/rpi/machconfig
diff --git a/meta-raspberrypi/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-raspberrypi/recipes-bsp/formfactor/formfactor_%.bbappend
index 72d991c7e..72d991c7e 100644
--- a/meta-raspberrypi/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ b/meta-raspberrypi/recipes-bsp/formfactor/formfactor_%.bbappend
diff --git a/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb b/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
index 0106ac3ff..593fc903e 100644
--- a/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
+++ b/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
@@ -1,6 +1,6 @@
SUMMARY = "U-boot boot scripts for Raspberry Pi"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
COMPATIBLE_MACHINE = "^rpi$"
DEPENDS = "u-boot-mkimage-native"
diff --git a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth.bb b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
index e185f25e2..e185f25e2 100644
--- a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth.bb
+++ b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
diff --git a/meta-raspberrypi/recipes-core/images/rpi-hwup-image.bb b/meta-raspberrypi/recipes-core/images/rpi-hwup-image.bb
index d2371ad25..86e9b6daf 100644
--- a/meta-raspberrypi/recipes-core/images/rpi-hwup-image.bb
+++ b/meta-raspberrypi/recipes-core/images/rpi-hwup-image.bb
@@ -7,5 +7,5 @@ IMAGE_INSTALL += " \
"
do_image_prepend() {
- bb.warn("The image 'rpi-hwup-image' is deprecated, please use 'core-image-minimal' instead")
+ bb.warn("The image 'rpi-hwup-image' is deprecated, please use 'core-image-base' instead")
}
diff --git a/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb b/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb
index 029c18cb7..d91ce0b31 100644
--- a/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb
+++ b/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "RaspberryPi Test Packagegroup"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
inherit packagegroup
diff --git a/meta-raspberrypi/recipes-core/psplash/psplash_git.bbappend b/meta-raspberrypi/recipes-core/psplash/psplash_%.bbappend
index 698564b94..698564b94 100644
--- a/meta-raspberrypi/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-raspberrypi/recipes-core/psplash/psplash_%.bbappend
diff --git a/meta-raspberrypi/recipes-core/udev/udev-rules-rpi.bb b/meta-raspberrypi/recipes-core/udev/udev-rules-rpi.bb
index b249d9726..edef0db9e 100644
--- a/meta-raspberrypi/recipes-core/udev/udev-rules-rpi.bb
+++ b/meta-raspberrypi/recipes-core/udev/udev-rules-rpi.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "udev rules for Raspberry Pi Boards"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
SRC_URI = " file://99-com.rules"
diff --git a/meta-raspberrypi/recipes-devtools/wiringPi/files/0001-Add-initial-cross-compile-support.patch b/meta-raspberrypi/recipes-devtools/wiringpi/files/0001-Add-initial-cross-compile-support.patch
index 01e054634..01e054634 100644
--- a/meta-raspberrypi/recipes-devtools/wiringPi/files/0001-Add-initial-cross-compile-support.patch
+++ b/meta-raspberrypi/recipes-devtools/wiringpi/files/0001-Add-initial-cross-compile-support.patch
diff --git a/meta-raspberrypi/recipes-devtools/wiringPi/wiringpi_git.bb b/meta-raspberrypi/recipes-devtools/wiringpi/wiringpi_git.bb
index f1b01dbe5..f1b01dbe5 100644
--- a/meta-raspberrypi/recipes-devtools/wiringPi/wiringpi_git.bb
+++ b/meta-raspberrypi/recipes-devtools/wiringpi/wiringpi_git.bb
diff --git a/meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
index 919e95e0d..919e95e0d 100644
--- a/meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb
index 0478576de..acbd2250c 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb
@@ -1,6 +1,6 @@
-LINUX_VERSION ?= "4.14.39"
+LINUX_VERSION ?= "4.14.58"
-SRCREV = "865ddc1393f558198e7e7ce70928ff2e49c4f7f6"
+SRCREV = "a06f9e522301dfacc1f382d72e6a9792d8350328"
SRC_URI = " \
git://github.com/raspberrypi/linux.git;branch=rpi-4.14.y \
file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \
diff --git a/meta-raspberrypi/recipes-multimedia/x264/x264_git.bbappend b/meta-raspberrypi/recipes-multimedia/x264/x264_%.bbappend
index 505719efb..505719efb 100644
--- a/meta-raspberrypi/recipes-multimedia/x264/x264_git.bbappend
+++ b/meta-raspberrypi/recipes-multimedia/x264/x264_%.bbappend
OpenPOWER on IntegriCloud