summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-05-07 15:42:31 +0200
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 17:02:24 -0400
commitf27bdd5a35e1af32ca3e200810222230d5fbee44 (patch)
treef2a27a208c72553cb2d0112bb3104c148aa9ce60 /meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
parentb19b94b9dcd289f0fae54a4fde03d3df401c96ab (diff)
downloadtalos-openbmc-f27bdd5a35e1af32ca3e200810222230d5fbee44.tar.gz
talos-openbmc-f27bdd5a35e1af32ca3e200810222230d5fbee44.zip
meta-raspberrypi: sumo refresh 05f21adb99..ade31d6d01
Update meta-raspberrypi to sumo HEAD. Andrei Gherzan (4): raspberrypi3-64.conf: Include cm3 dtb linux-raspberrypi: Update to v4.14.58 rpi-base.inc: Split overlays and dtbs from KERNEL_DEVICETREE raspberrypi3-64.conf: Define only the dtb files that are available for arch64 Anton Gerasimov (3): rpi-base.inc: install at86rf233 overlay rpi-config: load at86rf233 overlay docs: document support for 802.15.4 hat Eduardo Abinader (1): config_git.bb: Remove extra space Hugo Hromic (5): formfactor: use `rpi` instead of `raspberrypi` to apply to all rpi machines meta-raspberrypi: use `_%` suffix instead of specific versions for bbappends pi-bluetooth: use `_git` suffix in recipe filename meta-raspberrypi: use generic licenses in ${COMMON_LICENSE_DIR} from Poky wiringpi: use lower-case in recipe directory name Khem Raj (2): firmware: Update to 20180619 release linux-raspberrypi: Update to 4.14.52+ Martin Jansa (3): sdcard_image-rpi.bbclass: copy the DTB files with canonical name sdcard_image-rpi: add dependency on rpi-u-boot-scr sdcard_image-rpi.bbclass: use 4 spaces for indentation instead of mix of tabs and spaces Steve Pavao (1): rpi-hwup-image.bb: Modified the warning message in do_image_prepend() Change-Id: If6ee02907ad0f08816eb4d5dad9c92f0d93e252c Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb')
-rw-r--r--meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
new file mode 100644
index 000000000..e185f25e2
--- /dev/null
+++ b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Script to properly configure BT-HCI on Raspberry Pi"
+HOMEPAGE = "https://github.com/RPi-Distro/pi-bluetooth"
+SECTION = "kernel"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "\
+ file://debian/copyright;md5=6af8de3c8ee71f8e91e9b22f84ff2022 \
+"
+
+SRC_URI = "git://github.com/RPi-Distro/pi-bluetooth"
+SRCREV = "2a7477966bb3c69838b224f3ea92cb49a88124d5"
+UPSTREAM_VERSION_UNKNOWN = "1"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/usr/bin/btuart ${D}${bindir}
+}
+
+FILES_${PN} = "${bindir}"
OpenPOWER on IntegriCloud