summaryrefslogtreecommitdiffstats
path: root/meta-quanta
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-04-10 07:34:36 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-11 15:01:41 -0400
commit29e35284758b2d976ffa36e0d79237fd9f4463dd (patch)
tree720c4d839646cbbd5d698c59c072d0ebfcbabe74 /meta-quanta
parent0e6e9b20ff97513b7c0d17c48b7f70a7bde18c07 (diff)
downloadtalos-openbmc-29e35284758b2d976ffa36e0d79237fd9f4463dd.tar.gz
talos-openbmc-29e35284758b2d976ffa36e0d79237fd9f4463dd.zip
meta-quanta: q71l: powerctrl: install scripts in bin
Install the power control shell scripts into bin instead of sbin. These control power for the host, not the BMC. (From meta-quanta rev: 77c5f7af4311516e393cda73db75c907acd1171d) Signed-off-by: Patrick Venture <venture@google.com> Change-Id: I5294196516d458d6bbf930a287e42ceea1bc88e2 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-quanta')
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb b/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb
index 940b72d3f..f6f6458bf 100644
--- a/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb
+++ b/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb
@@ -21,8 +21,8 @@ SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
do_install() {
- install -d ${D}/usr/sbin
- install -m 0755 ${S}init_once.sh ${D}/${sbindir}/
- install -m 0755 ${S}poweroff.sh ${D}/${sbindir}/
- install -m 0755 ${S}poweron.sh ${D}/${sbindir}/
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}init_once.sh ${D}/${bindir}/
+ install -m 0755 ${S}poweroff.sh ${D}/${bindir}/
+ install -m 0755 ${S}poweron.sh ${D}/${bindir}/
}
OpenPOWER on IntegriCloud