summaryrefslogtreecommitdiffstats
path: root/meta-quanta/meta-gsj
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-06 13:58:07 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-06 14:11:45 -0400
commitfc81e38aed2df98ed8c83b3ce7970f6434765a41 (patch)
tree0ed58adcb31a230146652e2d2e37f14f5906b333 /meta-quanta/meta-gsj
parent9d8e46dcee0a07bc206e8980c7d9df0027935121 (diff)
downloadtalos-openbmc-fc81e38aed2df98ed8c83b3ce7970f6434765a41.tar.gz
talos-openbmc-fc81e38aed2df98ed8c83b3ce7970f6434765a41.zip
update upstream subtrees
A number of corequisites exist so squashing these all into one patch. meta-ingrasys - refresh master bc513127f4..67bcaf389f meta-hxt - refresh master 86a4df514f..8fe0d38bbb meta-phosphor - refresh master 06c09d7cce..df6ddae3d2 meta-quanta - refresh master 4f126361a1..53f3025271 Change-Id: I3daeef2a0467d8ea4f1fd1c617e526f8b11258af Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-quanta/meta-gsj')
-rw-r--r--meta-quanta/meta-gsj/conf/machine/gsj.conf1
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-sensor-map-native.bb19
-rwxr-xr-xmeta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-sensor-map/config.yaml527
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend2
4 files changed, 548 insertions, 1 deletions
diff --git a/meta-quanta/meta-gsj/conf/machine/gsj.conf b/meta-quanta/meta-gsj/conf/machine/gsj.conf
index e88e0583c..4e4f64d3f 100644
--- a/meta-quanta/meta-gsj/conf/machine/gsj.conf
+++ b/meta-quanta/meta-gsj/conf/machine/gsj.conf
@@ -25,3 +25,4 @@ PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-gsj-apps"
PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-gsj-apps"
PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "gsj-ipmi-inventory-map-native"
PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-read-inventory = "gsj-ipmi-fru-read-inventory-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-sensor-inventory = "gsj-ipmi-sensor-map-native"
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-sensor-map-native.bb b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-sensor-map-native.bb
new file mode 100644
index 000000000..b716bf054
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-sensor-map-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Quanta gsj IPMI to DBus Sensor mapping."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit phosphor-ipmi-host
+
+PROVIDES += "virtual/phosphor-ipmi-sensor-inventory"
+
+SRC_URI += "file://config.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${sensor_datadir}
+ install -d ${DEST}
+ install config.yaml ${DEST}/sensor.yaml
+}
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-sensor-map/config.yaml b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-sensor-map/config.yaml
new file mode 100755
index 000000000..daba925cf
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-sensor-map/config.yaml
@@ -0,0 +1,527 @@
+0x30:
+ entityID: 0x06
+ entityInstance: 1
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/KL0
+ sensorReadingType: 0x01
+ bExp: 0
+ rExp: 0
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x31:
+ entityID: 0x0D
+ entityInstance: 1
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/KL1
+ sensorReadingType: 0x01
+ bExp: 0
+ rExp: 0
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x32:
+ entityID: 0x0E
+ entityInstance: 1
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/KL2
+ sensorReadingType: 0x01
+ bExp: 0
+ rExp: 0
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x33:
+ entityID: 0x0E
+ entityInstance: 2
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/KL3
+ sensorReadingType: 0x01
+ bExp: 0
+ rExp: 0
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x3C:
+ entityID: 0x0A
+ entityInstance: 1
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/P48V_HSC_Temp
+ sensorReadingType: 0x01
+ bExp: 0
+ rExp: 0
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x70:
+ entityID: 0x0A
+ entityInstance: 5
+ sensorType: 0x03
+ path: /xyz/openbmc_project/sensors/current/P48V_HSC_Current
+ sensorReadingType: 0x01
+ multiplierM: 9
+ offsetB: 0
+ bExp: 0
+ rExp: -2
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Amperes
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x60:
+ entityID: 0x0A
+ entityInstance: 3
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/P48V_HSC_Vol
+ sensorReadingType: 0x01
+ multiplierM: 243
+ offsetB: 0
+ bExp: 0
+ rExp: -3
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x90:
+ entityID: 0x0A
+ entityInstance: 6
+ sensorType: 0x0B
+ path: /xyz/openbmc_project/sensors/power/P48V_HSC_Power
+ sensorReadingType: 0x01
+ multiplierM: 310
+ offsetB: 4
+ bExp: 2
+ rExp: -2
+ scale: -6
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x3D:
+ entityID: 0x0A
+ entityInstance: 2
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/P12V_BRIC_Temp
+ sensorReadingType: 0x01
+ bExp: 0
+ rExp: 0
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x71:
+ entityID: 0x0A
+ entityInstance: 7
+ sensorType: 0x03
+ path: /xyz/openbmc_project/sensors/current/P12V_BRIC_Current
+ sensorReadingType: 0x01
+ multiplierM: 200
+ offsetB: 0
+ bExp: 0
+ rExp: -3
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Amperes
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x61:
+ entityID: 0x0A
+ entityInstance: 4
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/P12V_BRIC_Vol
+ sensorReadingType: 0x01
+ multiplierM: 509
+ offsetB: 0
+ bExp: 0
+ rExp: -4
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+
+0x80:
+ entityID: 0x1D
+ entityInstance: 1
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan0_0_RPM
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ rExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x81:
+ entityID: 0x1D
+ entityInstance: 2
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan0_1_RPM
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ rExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x82:
+ entityID: 0x1D
+ entityInstance: 3
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan1_0_RPM
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ rExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x83:
+ entityID: 0x1D
+ entityInstance: 4
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan1_1_RPM
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ rExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x84:
+ entityID: 0x1D
+ entityInstance: 5
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan2_0_RPM
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ rExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x85:
+ entityID: 0x1D
+ entityInstance: 6
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan2_1_RPM
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ rExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0x34:
+ entityID: 0x07
+ entityInstance: 1
+ sensorType: 0x01
+ path: /xyz/openbmc_project/nvme/1
+ sensorReadingType: 0x01
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameParentLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x35:
+ entityID: 0x07
+ entityInstance: 2
+ sensorType: 0x01
+ path: /xyz/openbmc_project/nvme/2
+ sensorReadingType: 0x01
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameParentLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x36:
+ entityID: 0x07
+ entityInstance: 3
+ sensorType: 0x01
+ path: /xyz/openbmc_project/nvme/3
+ sensorReadingType: 0x01
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameParentLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x37:
+ entityID: 0x07
+ entityInstance: 4
+ sensorType: 0x01
+ path: /xyz/openbmc_project/nvme/4
+ sensorReadingType: 0x01
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameParentLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x38:
+ entityID: 0x07
+ entityInstance: 5
+ sensorType: 0x01
+ path: /xyz/openbmc_project/nvme/5
+ sensorReadingType: 0x01
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameParentLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x39:
+ entityID: 0x07
+ entityInstance: 6
+ sensorType: 0x01
+ path: /xyz/openbmc_project/nvme/6
+ sensorReadingType: 0x01
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameParentLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x3A:
+ entityID: 0x07
+ entityInstance: 7
+ sensorType: 0x01
+ path: /xyz/openbmc_project/nvme/7
+ sensorReadingType: 0x01
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameParentLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+0x3B:
+ entityID: 0x07
+ entityInstance: 8
+ sensorType: 0x01
+ path: /xyz/openbmc_project/nvme/8
+ sensorReadingType: 0x01
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameParentLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0xB0:
+ entityID: 0x20
+ entityInstance: 1
+ sensorType: 0x0C
+ path: /xyz/openbmc_project/memory/BmcECC
+ sensorReadingType: 0x6F
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: assertion
+ mutability: Mutability::Read
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Memory.MemoryECC:
+ state:
+ Offsets:
+ 0x00:
+ type: string
+ assert: xyz.openbmc_project.Sensor.Memory.MemoryECC.ECCStatus.CE
+ 0x01:
+ type: string
+ assert: xyz.openbmc_project.Sensor.Memory.MemoryECC.ECCStatus.UE
+ 0x05:
+ type: string
+ assert: xyz.openbmc_project.Sensor.Memory.MemoryECC.ECCStatus.LogFulled \ No newline at end of file
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
index 0fb703bc0..32989f2bb 100644
--- a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
+++ b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -13,7 +13,7 @@ ENVFMT = "obmc/eeproms/{0}"
SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gsj := " ${@compose_list(d, 'ENVFMT', 'EEPROMS')}"
TMPL = "obmc-read-eeprom@.service"
-TGT = "${SYSTEMD_DEFAULT_TARGET}"
+TGT = "multi-user.target"
INSTFMT = "obmc-read-eeprom@{0}.service"
FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
OpenPOWER on IntegriCloud