summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2018-07-11 09:20:02 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-07-24 13:45:12 +0000
commitcffe1bf83203854489e7b8bab81c9188143f7ab5 (patch)
tree7908b86eb5a3b17ea4124f93fc2f0c0924025f59 /meta-phosphor
parente9722d1bee556ee4d69ff1a1221d629b6c7759ec (diff)
downloadtalos-openbmc-cffe1bf83203854489e7b8bab81c9188143f7ab5.tar.gz
talos-openbmc-cffe1bf83203854489e7b8bab81c9188143f7ab5.zip
Disable forwarding of journal to syslog
systemd recently changed the default in their recipe to forward all messages on to syslog. OpenBMC runs in a constrained environment so the redundancy of having the logs in both journald and syslog does not make sense. Tested: Verified journal no longer tries to forward messgages on to syslog. Resolves openbmc/openbmc#3299 Change-Id: Ic7a8e488b60e984670ab4de666f820eeffe39afb Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb3
-rw-r--r--meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy/disable-forward-to-syslog.conf11
2 files changed, 14 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb b/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb
index ce58a532a..fbd492b7d 100644
--- a/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb
+++ b/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy.bb
@@ -9,12 +9,15 @@ DEPENDS += "systemd"
SRC_URI = "file://service-restart-policy.conf"
SRC_URI += "file://disable-duplicate-kernel-msg.conf"
+SRC_URI += "file://disable-forward-to-syslog.conf"
FILES_${PN} += "${systemd_unitdir}/system.conf.d/service-restart-policy.conf"
FILES_${PN} += "${systemd_unitdir}/journald.conf.d/disable-duplicate-kernel-msg.conf"
+FILES_${PN} += "${systemd_unitdir}/journald.conf.d/disable-forward-to-syslog.conf"
do_install() {
install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${systemd_unitdir}/system.conf.d/service-restart-policy.conf
install -m 644 -D ${WORKDIR}/disable-duplicate-kernel-msg.conf ${D}${systemd_unitdir}/journald.conf.d/disable-duplicate-kernel-msg.conf
+ install -m 644 -D ${WORKDIR}/disable-forward-to-syslog.conf ${D}${systemd_unitdir}/journald.conf.d/disable-forward-to-syslog.conf
}
diff --git a/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy/disable-forward-to-syslog.conf b/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy/disable-forward-to-syslog.conf
new file mode 100644
index 000000000..c85bceade
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/systemd-policy/phosphor-systemd-policy/disable-forward-to-syslog.conf
@@ -0,0 +1,11 @@
+# This file overrides some defaults for systemd
+#
+# systemd recently changed the default in their recipe
+# to forward all messages on to syslog. OpenBMC runs in
+# a constrained environment so the redundancy of having
+# the logs in both journald and syslog does not make sense.
+#
+# See systemd-system.conf(5) for details on the conf files
+
+[Journal]
+ForwardToSyslog=no
OpenPOWER on IntegriCloud