summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorRaptor Engineering Development Team <support@raptorengineering.com>2018-01-20 01:50:01 -0600
committerTimothy Pearson <tpearson@raptorengineering.com>2019-04-25 08:01:50 +0000
commit8010e19ff1216ee994f41c141deaf28d72a02da9 (patch)
tree9eca0b86d152fa369c8d82896c6b071bf18cb3a6 /meta-phosphor
parent336e31aa1d3f1b04eac8c403669c597251d0d1ec (diff)
downloadtalos-openbmc-8010e19ff1216ee994f41c141deaf28d72a02da9.tar.gz
talos-openbmc-8010e19ff1216ee994f41c141deaf28d72a02da9.zip
Add IPL monitor LED service
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-led-monitor.bb23
-rw-r--r--meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-led-monitor/org.openbmc.status.IPLLED.service15
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-led-monitor.bb b/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-led-monitor.bb
new file mode 100644
index 000000000..cf4520368
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-led-monitor.bb
@@ -0,0 +1,23 @@
+SUMMARY = "OpenBMC IPL status LED monitor"
+DESCRIPTION = "OpenBMC IPL status LED monitor."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-subprocess \
+ python-pygobject \
+ pyphosphor \
+ pyphosphor-dbus \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ obmc-ipl-status-observer \
+ "
+
+SKELETON_DIR = "pyiplledmonitor"
+
+DBUS_SERVICE_${PN} += "org.openbmc.status.IPLLED.service"
diff --git a/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-led-monitor/org.openbmc.status.IPLLED.service b/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-led-monitor/org.openbmc.status.IPLLED.service
new file mode 100644
index 000000000..2385a8877
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-led-monitor/org.openbmc.status.IPLLED.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Phoshpor IPL Status LED Monitor
+Wants=org.openbmc.status.IPL.service
+After=org.openbmc.status.IPL.service
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env ipl_status_led_monitor.py
+SyslogIdentifier=ipl_status_led_monitor.py
+Type=dbus
+BusName={BUSNAME}
+Environment="PYTHONUNBUFFERED=1"
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
OpenPOWER on IntegriCloud