summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorRichard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>2018-12-14 09:04:40 +0530
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-12-18 12:47:39 +0000
commit7a8e9b29c5f6d0b8153a8e226097e8bcbb0fd554 (patch)
treed2150fd2395229fb463e21104b0bbe082110fe2e /meta-phosphor
parent365ec7aa27c9f22f80f9c87df9d16b9b24d8e1ab (diff)
downloadtalos-openbmc-7a8e9b29c5f6d0b8153a8e226097e8bcbb0fd554.tar.gz
talos-openbmc-7a8e9b29c5f6d0b8153a8e226097e8bcbb0fd554.zip
Add root user to required groups as per recipe
root user has to be added to groups accordingly based on the recipe. i.e. phosphor-ipmi-host_git.bb, will create both ipmi group, and add root user to the same. Unit-test: 1. Verified root user is added to the groups accordingly. (From meta-phosphor rev: 41882fbf717f267b280ab8ed3393f1178a029258) Change-Id: I79d3a23fd939f38064999ebe99f17f3e0c02ed0c Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb4
3 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index 40ec570a4..46dba1445 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -6,6 +6,8 @@ USERADD_PACKAGES = "${PN}"
# add a user called httpd for the server to assume
USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb"
GROUPADD_PARAM_${PN} = "web; redfish"
+# Add root user to web & redfish group
+GROUPMEMS_PARAM_${PN} = "-g web -a root; -g redfish -a root"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index f576aec9e..e85b2609c 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -56,6 +56,8 @@ inherit useradd
USERADD_PACKAGES = "${PN}"
# add ipmi group
GROUPADD_PARAM_${PN} = "ipmi"
+# Add root user to ipmi group
+GROUPMEMS_PARAM_${PN} = "-g ipmi -a root"
SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
diff --git a/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb b/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
index 6f65feef7..1e9747a17 100644
--- a/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
@@ -26,6 +26,10 @@ DBUS_PACKAGES = "${USERADD_PACKAGES}"
# add groups needed for privilege maintenance
GROUPADD_PARAM_${PN} = "priv-admin; priv-operator; priv-user; priv-callback "
GROUPADD_PARAM_phosphor-ldap = "priv-admin; priv-operator; priv-user; priv-callback "
+
+# Add root user to priv-admin group
+GROUPMEMS_PARAM_${PN} = "-g priv-admin -a root"
+
DBUS_SERVICE_${PN} += "xyz.openbmc_project.User.Manager.service"
FILES_phosphor-ldap += " \
${sbindir}/phosphor-ldap-conf \
OpenPOWER on IntegriCloud