summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorEddie James <eajames@us.ibm.com>2018-04-04 13:53:13 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-07-16 02:46:28 +0000
commit65d42a8d271eea42050451e28c0eb859f322b47f (patch)
tree5c4adbd094667a3fc871bb5840fea6630a9091c0 /meta-phosphor
parenta467494a2ebf94a0145ada9b8b2d85fc92b90b9d (diff)
downloadtalos-openbmc-65d42a8d271eea42050451e28c0eb859f322b47f.tar.gz
talos-openbmc-65d42a8d271eea42050451e28c0eb859f322b47f.zip
busybox: patch "umount: ignore -c"
Upstream busybox has a change to ignore the -c option, which systemd uses when unmounting during shutdown/reboot. Currently, if -c is used, umount fails. This results in extensive umount failures during shutdown. See http://lists.busybox.net/pipermail/busybox/2018-January/086045.html Change-Id: I4630935dc5ec61263a7af9e24b70ca8f1f8b5359 Signed-off-by: Eddie James <eajames@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-core/busybox/busybox/0001-umount-ignore--c.patch49
-rw-r--r--meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-core/busybox/busybox/0001-umount-ignore--c.patch b/meta-phosphor/common/recipes-core/busybox/busybox/0001-umount-ignore--c.patch
new file mode 100644
index 000000000..0c8e83697
--- /dev/null
+++ b/meta-phosphor/common/recipes-core/busybox/busybox/0001-umount-ignore--c.patch
@@ -0,0 +1,49 @@
+From 24cd2c1c2893cf456bd93ed3091fca878bfc014f Mon Sep 17 00:00:00 2001
+From: Eddie James <eajames@us.ibm.com>
+Date: Thu, 5 Jul 2018 08:46:18 -0500
+Subject: [PATCH] umount: ignore -c
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+systemd uses -c.
+ -c, --no-canonicalize
+ Do not canonicalize paths. The paths canonicalization is based
+ on stat(2) and readlink(2) system calls. These system calls may
+ hang in some cases (for example on NFS if server is not avail‐
+ able). The option has to be used with canonical path to the
+ mount point.
+
+ For more details about this option see the mount(8) man page.
+ Note that umount does not pass this option to the
+ /sbin/umount.type helpers.
+
+As busybox doesn't canonicalize paths in the first place it is safe to
+ignore this option.
+
+See https://github.com/systemd/systemd/issues/7786
+
+Signed-off-by: Shawn Landden <slandden at gmail.com>
+Signed-off-by: Eddie James <eajames@us.ibm.com>
+---
+ util-linux/umount.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/util-linux/umount.c b/util-linux/umount.c
+index 0c50dc9..0425c5b 100644
+--- a/util-linux/umount.c
++++ b/util-linux/umount.c
+@@ -68,8 +68,8 @@ static struct mntent *getmntent_r(FILE* stream, struct mntent* result,
+ }
+ #endif
+
+-/* ignored: -v -t -i */
+-#define OPTION_STRING "fldnra" "vt:i"
++/* ignored: -c -v -t -i */
++#define OPTION_STRING "fldnra" "cvt:i"
+ #define OPT_FORCE (1 << 0) // Same as MNT_FORCE
+ #define OPT_LAZY (1 << 1) // Same as MNT_DETACH
+ #define OPT_FREELOOP (1 << 2)
+--
+1.8.3.1
+
diff --git a/meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend b/meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend
index e6678fc8a..5acaf3c2e 100644
--- a/meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend
+++ b/meta-phosphor/common/recipes-core/busybox/busybox_%.bbappend
@@ -3,3 +3,4 @@ SRC_URI += "file://busybox.cfg"
SRC_URI += "file://flash.cfg"
SRC_URI += "file://mountpoint.cfg"
SRC_URI += "file://0001-Stop-watchdog-first-on-startup.patch"
+SRC_URI += "file://0001-umount-ignore--c.patch"
OpenPOWER on IntegriCloud