summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-03-31 14:41:11 +0530
committerPatrick Williams <patrick@stwcx.xyz>2017-04-04 19:11:15 +0000
commitcaff3fa9c6150b1a2ac5f0edb5cdd7353e8681ef (patch)
tree6cbfbbf9678893e3d6e599359d3fbddcb28f272f /meta-phosphor
parent7a0b268ebfbdc1c82e3164e6a5be8b0fc72ab55f (diff)
downloadtalos-openbmc-caff3fa9c6150b1a2ac5f0edb5cdd7353e8681ef.tar.gz
talos-openbmc-caff3fa9c6150b1a2ac5f0edb5cdd7353e8681ef.zip
IPMI: Provide recipe file for soft power off service
Change-Id: I9d17bb3b90dee86e2290b8552bb519b0164c477c Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb13
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/op-stop-host@.service12
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/phosphor-ipmi-host.service (renamed from meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/org.openbmc.HostServices.service)2
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service9
4 files changed, 11 insertions, 25 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index 90b03eda9..5137a3cf7 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -28,6 +28,8 @@ RDEPENDS_${PN} += "libmapper"
RDEPENDS_${PN} += "phosphor-time-manager"
RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
+
RRECOMMENDS_${PN} += "virtual-obmc-settings-mgmt"
SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid"
@@ -46,7 +48,6 @@ EXTRA_OECONF = " \
S = "${WORKDIR}/git"
HOSTIPMI_PROVIDER_LIBRARY += "libapphandler.so"
-HOSTIPMI_PROVIDER_LIBRARY += "libhostservice.so"
HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
NETIPMI_PROVIDER_LIBRARY += "libapphandler.so"
@@ -56,15 +57,5 @@ FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
-DBUS_SERVICE_${PN} += "org.openbmc.HostServices.service"
-
# Soft Power Off
RDEPENDS_${PN} += "phosphor-mapper"
-
-TMPL = "op-stop-host@.service"
-INSTFMT = "op-stop-host@{0}.service"
-TGTFMT = "obmc-stop-host@{0}.target"
-FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
-
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/op-stop-host@.service b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/op-stop-host@.service
deleted file mode 100644
index 64ec0fbfa..000000000
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/op-stop-host@.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Soft power off of the host
-Conflicts=obmc-chassis-start@%i.target
-
-[Service]
-Restart=no
-Type=oneshot
-RemainAfterExit=yes
-ExecStart={sbindir}/mapper call /org/openbmc/HostServices org.openbmc.HostServices SoftPowerOff
-
-[Install]
-WantedBy=obmc-stop-host@%i.target
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/org.openbmc.HostServices.service b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/phosphor-ipmi-host.service
index f2bdb8c89..febbe87c8 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/org.openbmc.HostServices.service
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/phosphor-ipmi-host.service
@@ -8,8 +8,6 @@ After=mapper-wait@-org-openbmc-settings-host0.service
[Service]
Restart=always
ExecStart={sbindir}/ipmid
-Type=dbus
-BusName={BUSNAME}
[Install]
WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service
new file mode 100644
index 000000000..aaba630f2
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Soft power off of the host
+Wants=mapper-wait@-org-openbmc-HostIpmi-1.service
+After=mapper-wait@-org-openbmc-HostIpmi-1.service
+
+[Service]
+Restart=no
+ExecStart={sbindir}/phosphor-softpoweroff
+Type=oneshot
OpenPOWER on IntegriCloud