summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <andrewg@us.ibm.com>2017-05-31 20:37:10 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-06-03 12:57:48 +0000
commita9dcb06b757fe0d476b630f0f9d84b2cb6ce08de (patch)
treec3d602661719043f4138d34a2e32b7775ba03015 /meta-phosphor
parentcb6bc03cef3d4acc59f64ab8d628a8e208f6760d (diff)
downloadtalos-openbmc-a9dcb06b757fe0d476b630f0f9d84b2cb6ce08de.tar.gz
talos-openbmc-a9dcb06b757fe0d476b630f0f9d84b2cb6ce08de.zip
Ensure watchdog is disabled on chassis off
If the user elects to do a hard power off on a system via the chassis poweroff target, need to ensure we still disable the host watchdog. This service will now be called in both the host and chassis off targets. Change-Id: I83c8c1b657056dab0dbbaaea0dea230f9c3ade4e Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-watchdog.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-watchdog.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-watchdog.bb
index d065d631b..72aa0763f 100644
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-watchdog.bb
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-watchdog.bb
@@ -21,5 +21,12 @@ STOP_TGTFMT = "obmc-host-stop@{1}.target"
STOP_INSTFMT = "obmc-stop-watchdog@{0}.service"
STOP_FMT = "../${STOP_TMPL}:${STOP_TGTFMT}.requires/${STOP_INSTFMT}"
+# Ensure we also call the stop watchdog if the user
+# just directly cuts chassis power
+CHASSIS_TGTFMT= "obmc-chassis-poweroff@{1}.target"
+CHASSIS_FMT = "../${STOP_TMPL}:${CHASSIS_TGTFMT}.requires/${STOP_INSTFMT}"
+
+
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_WATCHDOG_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'STOP_FMT', 'OBMC_WATCHDOG_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'CHASSIS_FMT', 'OBMC_WATCHDOG_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
OpenPOWER on IntegriCloud