summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-07-11 13:25:47 -0500
committerGitHub <noreply@github.com>2016-07-11 13:25:47 -0500
commitb248dbdbed5550345c208f4d147a9873ce18e5e7 (patch)
tree519a3c5b783c421c59a9739feb797ffa969bc636 /meta-phosphor
parent104682feb3d4909b43befb0c23cde880cec88719 (diff)
parent9fb9242725cc5b188393aaf11523bccae2050dfc (diff)
downloadtalos-openbmc-b248dbdbed5550345c208f4d147a9873ce18e5e7.tar.gz
talos-openbmc-b248dbdbed5550345c208f4d147a9873ce18e5e7.zip
Merge pull request #461 from bradbishop/two-busses
Remove extra busses from python and sdbus examples
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py3
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService.conf (renamed from meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService0.conf)4
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService0.conf8
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService1.conf8
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py4
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb3
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c8
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService.conf (renamed from meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService1.conf)4
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb3
9 files changed, 10 insertions, 35 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py
index 2b59b5887..1f4ce90bb 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/obmc-phosphor-example-pydbus.py
@@ -86,8 +86,7 @@ if __name__ == '__main__':
bus = dbus.SystemBus()
services = []
- services.append(dbus.service.BusName(SERVICE_PREFIX + '.PythonService0', bus))
- services.append(dbus.service.BusName(SERVICE_PREFIX + '.PythonService1', bus))
+ services.append(dbus.service.BusName(SERVICE_PREFIX + '.PythonService', bus))
objs = []
objs.append(SampleObjectOne(bus, BASE_OBJ_PATH + 'path0/PythonObj'))
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService0.conf b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService.conf
index 45af4f4b6..6c4a71314 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService0.conf
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService.conf
@@ -2,7 +2,7 @@
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
<policy user="root">
- <allow own="org.openbmc.examples.SDBusService0"/>
- <allow send_destination="org.openbmc.examples.SDBusService0"/>
+ <allow own="org.openbmc.examples.PythonService"/>
+ <allow send_destination="org.openbmc.examples.PythonService"/>
</policy>
</busconfig>
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService0.conf b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService0.conf
deleted file mode 100644
index fad0b81fb..000000000
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService0.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy user="root">
- <allow own="org.openbmc.examples.PythonService0"/>
- <allow send_destination="org.openbmc.examples.PythonService0"/>
- </policy>
-</busconfig>
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService1.conf b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService1.conf
deleted file mode 100644
index 0f7114e48..000000000
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/org.openbmc.examples.PythonService1.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <policy user="root">
- <allow own="org.openbmc.examples.PythonService1"/>
- <allow send_destination="org.openbmc.examples.PythonService1"/>
- </policy>
-</busconfig>
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py
index e1010a542..138865db0 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/files/pyclient-sample.py
@@ -36,9 +36,9 @@ if __name__ == '__main__':
bus = dbus.SystemBus()
- obj0 = bus.get_object(SERVICE_PREFIX + '.PythonService0',
+ obj0 = bus.get_object(SERVICE_PREFIX + '.PythonService',
BASE_OBJ_PATH + 'path0/PythonObj')
- obj1 = bus.get_object(SERVICE_PREFIX + '.PythonService1',
+ obj1 = bus.get_object(SERVICE_PREFIX + '.PythonService',
BASE_OBJ_PATH + 'path1/PythonObj')
echo0= dbus.Interface(obj0,
dbus_interface=IFACE_PREFIX + '.Echo')
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
index 1446a7313..57e27cf78 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-pydbus/obmc-phosphor-example-pydbus.bb
@@ -3,8 +3,7 @@ DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation."
PR = "r1"
DBUS_SERVICES = " \
- org.openbmc.examples.PythonService0 \
- org.openbmc.examples.PythonService1 \
+ org.openbmc.examples.PythonService \
"
inherit obmc-phosphor-pydbus-service
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c
index a66bb555c..769a2081f 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/obmc-phosphor-example-sdbus.c
@@ -79,13 +79,7 @@ int main(int argc, char *argv[]) {
}
/* Take a well-known service name so that clients can find us */
- r = sd_bus_request_name(bus, "org.openbmc.examples.SDBusService0", 0);
- if (r < 0) {
- fprintf(stderr, "Failed to acquire service name: %s\n", strerror(-r));
- goto finish;
- }
-
- r = sd_bus_request_name(bus, "org.openbmc.examples.SDBusService1", 0);
+ r = sd_bus_request_name(bus, "org.openbmc.examples.SDBusService", 0);
if (r < 0) {
fprintf(stderr, "Failed to acquire service name: %s\n", strerror(-r));
goto finish;
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService1.conf b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService.conf
index 5a7bfb84e..86e2a53fa 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService1.conf
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/files/org.openbmc.examples.SDBusService.conf
@@ -2,7 +2,7 @@
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
<policy user="root">
- <allow own="org.openbmc.examples.SDBusService1"/>
- <allow send_destination="org.openbmc.examples.SDBusService1"/>
+ <allow own="org.openbmc.examples.SDBusService"/>
+ <allow send_destination="org.openbmc.examples.SDBusService"/>
</policy>
</busconfig>
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
index f1a9eb962..9a3018d37 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-example-sdbus/obmc-phosphor-example-sdbus.bb
@@ -3,8 +3,7 @@ DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation."
PR = "r1"
DBUS_SERVICES = " \
- org.openbmc.examples.SDBusService0 \
- org.openbmc.examples.SDBusService1 \
+ org.openbmc.examples.SDBusService \
"
S = "${WORKDIR}"
OpenPOWER on IntegriCloud