summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <andrewg@us.ibm.com>2017-01-10 15:12:03 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-01-18 21:39:44 +0000
commitd8f5cc2fd22d40460402de3e634421a4bf41ede7 (patch)
tree402fb5fe5eb61990c5fe58be635943572471e8e9 /meta-phosphor
parent9cd1b33576970f963aff8b778031e2b2e8dd22fe (diff)
downloadtalos-openbmc-d8f5cc2fd22d40460402de3e634421a4bf41ede7.tar.gz
talos-openbmc-d8f5cc2fd22d40460402de3e634421a4bf41ede7.zip
Initial recipe for phosphor-host-state-manager
Delivers the phosphor-host-state-manager application which provides control and query functions on the host objects in the system Change-Id: I8bb91b44873edf3e9836d16a19bce1d2748c9f51 Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/state/phosphor-host-state-manager.bb26
-rw-r--r--meta-phosphor/common/recipes-phosphor/state/phosphor-host-state-manager/xyz.openbmc_project.State.Host.service14
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-host-state-manager.bb b/meta-phosphor/common/recipes-phosphor/state/phosphor-host-state-manager.bb
new file mode 100644
index 000000000..cde6004fd
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-host-state-manager.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Phosphor Host State Management"
+DESCRIPTION = "Phosphor Host State Manager provides a host state \
+object which manages the hosts in the system. It is suitable for use on \
+a wide variety of OpenBMC platforms."
+HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-dbus-service
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.State.Host.service"
+
+RDEPENDS_${PN} += "libsystemd"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-logging"
+
+PROVIDES += "virtual/obmc-host-state-mgmt"
+RPROVIDES_${PN} += "virtual-obmc-host-state-mgmt"
+
+SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
+SRCREV = "794baed325213d39d75e5f8c3374177891ef70ec"
+
+S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-host-state-manager/xyz.openbmc_project.State.Host.service b/meta-phosphor/common/recipes-phosphor/state/phosphor-host-state-manager/xyz.openbmc_project.State.Host.service
new file mode 100644
index 000000000..8fd2ed351
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-host-state-manager/xyz.openbmc_project.State.Host.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Phosphor Host State Manager
+Wants=mapper-wait@-org-openbmc-managers-System.service
+After=mapper-wait@-org-openbmc-managers-System.service
+Before=mapper-wait@-xyz-openbmc_project-state-host.service
+
+[Service]
+ExecStart={sbindir}/phosphor-host-state-manager
+Restart=always
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
OpenPOWER on IntegriCloud