summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-05-06 20:35:43 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-05-17 10:25:52 -0400
commitd1bcf3dc1483a0af46e86635363e952b4cd56a52 (patch)
treea4c753cae19f804e6996f9677ae68f85f75aeeca /meta-phosphor
parentbdff56965d3457d53c488bbf50d2793d9b5983e9 (diff)
downloadtalos-openbmc-d1bcf3dc1483a0af46e86635363e952b4cd56a52.tar.gz
talos-openbmc-d1bcf3dc1483a0af46e86635363e952b4cd56a52.zip
Re-enable out of tree device trees
This snippet was mistakenly removed with 8ef9fee. Note that this isn't a matter of policy, it simply enables the option to do it. The in-tree device tree is still the default. This enables things like workbook or schematic generated device trees. It also addresses the inevitable fact that the upstream kernel will probably not want device trees for every board in the world. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
index 24cde9f87..945b43d9f 100644
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.4.bb
@@ -18,3 +18,13 @@ COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
+
+do_patch_append() {
+ for DTB in "${KERNEL_DEVICETREE}"; do
+ DT=`basename ${DTB} .dtb`
+ if [ -r "${WORKDIR}/${DT}.dts" ]; then
+ cp ${WORKDIR}/${DT}.dts \
+ ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
+ fi
+ done
+}
OpenPOWER on IntegriCloud