summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2016-03-17 17:35:27 +0800
committerJeremy Kerr <jk@ozlabs.org>2016-03-24 17:17:55 +0800
commit882199ec4242171335b724fa35b9ba637f46fbc8 (patch)
tree316a1aff9062cb7e822dd3471f63b5ccc260644e /meta-phosphor
parent2fe86d90044af218ced8f42fdded6b136f1046d2 (diff)
downloadtalos-openbmc-882199ec4242171335b724fa35b9ba637f46fbc8.tar.gz
talos-openbmc-882199ec4242171335b724fa35b9ba637f46fbc8.zip
Add obmc-console project
This change introduces obmc-console, a little daemon to handle the UART data and multiplex it to a log and client processes. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/obmc-phosphor-image.bbclass1
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console.bb21
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console/obmc-console.conf3
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console/obmc-console.service9
4 files changed, 34 insertions, 0 deletions
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index 164da3318..ce54777bc 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -42,6 +42,7 @@ IMAGE_INSTALL += " \
i2c-tools \
screen \
inarp \
+ obmc-console \
"
def build_overlay(d):
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console.bb b/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console.bb
new file mode 100644
index 000000000..6fe3bdee1
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console.bb
@@ -0,0 +1,21 @@
+SUMMARY = "OpenBMC console daemon"
+DESCRIPTION = "Daemon to handle UART console connections"
+HOMEPAGE = "http://github.com/openbmc/obmc-console"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+inherit autotools
+
+TARGET_CFLAGS += "-fpic -O2"
+
+SRC_URI += "git://github.com/openbmc/obmc-console"
+SRC_URI += "file://${PN}.conf"
+SRCREV = "54e9569d14b127806e45e1c17ec4a1f5f7271d3f"
+
+do_install_append() {
+ install -m 0755 -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
+}
+
+S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console/obmc-console.conf b/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console/obmc-console.conf
new file mode 100644
index 000000000..d324efce5
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console/obmc-console.conf
@@ -0,0 +1,3 @@
+device = ttyS5
+lpc-address = 0x3f8
+sirq = 4
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console/obmc-console.service b/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console/obmc-console.service
new file mode 100644
index 000000000..4e0854198
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-console/obmc-console/obmc-console.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=OpenBMC console daemon
+
+[Service]
+ExecStart=/usr/sbin/obmc-console-server
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
OpenPOWER on IntegriCloud